RMSEA Confidence Interval PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 Daniel posted on Wednesday, February 08, 2006 - 1:48 pm
I looked in your technical appendices and could not find the limits of the RMSEA confidence interval. Is it a 90% CI?
 Linda K. Muthen posted on Wednesday, February 08, 2006 - 3:10 pm
It is a 95% confidence interval.
 Phil posted on Tuesday, February 21, 2006 - 9:53 pm
Under "TESTS of MODEL FIT" in the Mplus results, there are two model fits: (1) Chi-Square Test of Model Fit; (2) Chi-Square Test of Model Fit for the Baseline Model. Which one should I use? Is good model with small Chi-Square statistic? How to use this Chi-Square statistic to evaluate a model (e.g., Chi-Square/df < 5)?
 Linda K. Muthen posted on Tuesday, February 21, 2006 - 10:05 pm
You should use the Chi-square test of model fit. The other is for the baseline model that is used for CFI and TLI. Usually, one looks for a p-value greater than .05.
 Phil posted on Tuesday, February 28, 2006 - 3:17 pm
Dear Linda,
How to obtain 90% CIs of RMSEA in SEM? Thanks.
 Linda K. Muthen posted on Tuesday, February 28, 2006 - 4:44 pm
If it is not given for your analysis, it has most likely not been developed for that situation. If you want a more specific answer, send your input, data, output, and license number to support@statmodel.com.
 Joseph posted on Tuesday, February 28, 2006 - 5:24 pm
What is the criterion for the WRMR in Mplus? What does "StdYX" mean in model results? Thanks.
 Linda K. Muthen posted on Tuesday, February 28, 2006 - 8:56 pm
We recommend a value less than or equal to one. We do not recommend this for growth models with many time points or for multiple group analysis.

See pages 503-504 of the Version 4 Mplus User's Guide for a description of StdYX.
 hans beeman posted on Thursday, November 30, 2006 - 11:04 pm
Hello Drs. Muthén,

using the MLR estimator, MPlus does not give RMSEA confidence intervals. I read in the MPlus forum that a technique to compute confidence intervals for RMSEAs while using MLR has not yet been developed. Hence, I was surprised to read a paper recently (Zimprich, Allemand, & Hornung, 2006 [European Journal of Psychological Assessment]) that reported 95% confidence intervals for RMSEA, having used the MPlus MLR estimator.

It appears the authors have a posteriori implemented the T2* statistic into the formula given in MacCallum, Browne, and Sugawara (1996) [Psychological Methods].

My question is: As I need CIs for my RMSEAs (using MLR) too - is this procedure possible?
 Linda K. Muthen posted on Thursday, December 07, 2006 - 3:49 pm
We have looked at the paper and think this looks good. We will add it in a future update.
 J.-T. Kuhn posted on Wednesday, June 20, 2007 - 11:52 am
I have a question relating to the computation of the RMSEA in multiple group SEM/CFA in MPlus (Type=meanstructure). I have conducted a multiple groups CFA, constraining loadings and error variances across groups. How is the RMSEA calculated in MPlus for this?

The usual formula is

RMSEA = SQRT[d/df],

with d = chi^2 - df / (N - 1).

I have the following parameters:

Overall fit
N = 1328
df = 267
chi^2 = 518.178

Groupwise fit
Group 1
N = 305
df = 69
chi^2 = 149.139

Group2
N = 354
df = 66
chi^2 = 121.517

Group3
N = 358
df = 66
chi^2 = 136.735

Group4
N = 311
df = 66
chi^2 = 110.787

Using the parameters from the overall model, I get a RMSEA of
0.053 in MPlus, but using the formula above, I get 0.027. What is the reason for this? How is the RMSEA computed in this case?

Or is - in the multiple group setting - the RMSEA calculated groupwise and then averaged?

I'd greatly appreciate your help! I need to calculate RMSEA confidence intervals for MLM-estimates (rescaled), that's why I ask (RMSEA CIs are not given for MLM estimates).
 Linda K. Muthen posted on Wednesday, June 20, 2007 - 1:56 pm
The formula is:

RMSEA = SQRT[d/df] SQRT [G]

where G is the number of groups. See Technical Appendix 5, formula 125. The reference for this is also included.

If we don't give a confidence interval for RMSEA, then we believe the regular confidence interval is not appropriate.
 Bin Na Kim posted on Saturday, November 24, 2007 - 10:22 am
Dear Dr. Muthen,

I am a new Mplus user.
In performing SEM, I chose MLM as estimator, because I have non-normal continuous data.
I got a RMSEA of 0.033,
and I would like to know about the CI for RMSEA.

I found on the discussion board that RMSEA CI for MLM was not provided last December,and I wonder if it is still the case.

If it's not possible to obtain RMSEA CI for MLM, is there an alternative way to compute the CI or other indices that I can report instead of CI?

I always learn a lot from your comments on the board.
Many thanks in advance.

Kim, Bin Na
 Linda K. Muthen posted on Saturday, November 24, 2007 - 3:22 pm
There is no confidence interval available for the MLM estimator. I would look at the point estimate and use the suggested cutoff along with the other fit statistics.
 M Hamd posted on Saturday, April 03, 2010 - 11:28 pm
Heck (2001) say on p.109, "To test the complete (i.e., two-group) multilevel model with unbalanced group sizes, Muthen's robust quasi-likelihood estimator (MLM) should be used because it provides the correct chi-square coefficient and standard errors.With unbalanced group sizes, the RMSEA is incorrect, so only the chi-square can be used to estimate the overall model fit."

Is this correct that when I have unbalanced design, I can only interpret ch-sq. But for large sample sizes ch-sq test will seldom pass? I will appreciate any comments on this.

Ref: Heck, R. H. 2001. Multilevel modeling with SEM. In G. A. Marcoulides & R. E. Schumacker (Eds.), New developments and techniques in structural equation modeling: 89-127. Mahwah, NJ: Lawrence Erlbaum Associates, Inc.
 Bengt O. Muthen posted on Sunday, April 04, 2010 - 2:42 pm
Perhaps Heck was referring to the "MUML" estimator which is only ML with balanced data. In the current Mplus the regular ML estimator is the default and recommended estimator. Here, chi-2, RMSEA, and SEs are all correct also with unbalanced designs.
 M Hamd posted on Sunday, April 04, 2010 - 11:15 pm
Dr. Muthen
Thanks a lot.
 Mohamed Abou-Shouk posted on Thursday, April 28, 2011 - 2:45 pm
Hi,
for model fit indices in mplus, CFI, TLI should be above .9 or >= .95 to show a good model fit.

Any references.

Thanks,
 Bengt O. Muthen posted on Thursday, April 28, 2011 - 3:06 pm
See

Hu, L. & Bentler, P.M. (1998). Fit indices in covariance structure analysis:
Sensitivity to underparameterized model misspecification. Psychological
Methods, 3, 424-453.

Hu, L. & Bentler, P.M. (1999). Cutoff criterion for fit indices in covariance
structure analysis: conventional criteria versus new alternatives. Structural
Equation Modeling, 6, 1-55.

But note that more recent articles point out that a fixed cutoff like this is not suitable for all situations - Google the literature.
 Mohamed Abou-Shouk posted on Thursday, April 28, 2011 - 4:50 pm
Thanks,
I have one more question:
How to calculate the multivariate normaility in Mplus?

Thanks,
 Linda K. Muthen posted on Friday, April 29, 2011 - 3:14 pm
There is no option to do this in Mplus.
 Esperanza Camargo posted on Thursday, June 09, 2011 - 10:10 pm
Has been developed the 90% confidence band for the RMSEA?
 Linda K. Muthen posted on Thursday, June 09, 2011 - 11:14 pm
If you are asking for the case of categorical outcomes, yes. It has always been available for continuous outcomes.
 Esperanza Camargo Bernal posted on Tuesday, December 20, 2011 - 9:25 pm
I am runing a exploratory SEM using the WLSMV estimator. I do need to report the range of values and the confidence intervals for RMSEA; my output only provides the estimate value.

Is there any command I can use to get that information?
 Esperanza Camargo Bernal posted on Tuesday, December 20, 2011 - 9:41 pm
No need for an answer.

I already got the RMSEA information.

Thanks


Esperanza
 Jenny L.  posted on Saturday, June 01, 2013 - 7:43 pm
Dear Professors:

In one of the models I tested, the estimated RMSEA was 0.000, but 90% CI and probability<.05 were not provided. Was there something wrong in my model? (CFI=1.000, TLI=1.029)

Thank you for your kind help.
 Jenny L.  posted on Sunday, June 02, 2013 - 4:50 pm
Dear Professors,

I did an EFA and got an RMSEA estimate=.000, but there was no information on the 90% CI and probability =<.05. Could you tell me how I should interpret it?

Thank you in advance for your help.
 Jenny L.  posted on Sunday, June 02, 2013 - 4:52 pm
Oops, sorry for posting similar messages twice. I thought the first one disappeared...
 Linda K. Muthen posted on Monday, June 03, 2013 - 4:59 pm
You are either using an older version of Mplus or the CI and probability have not yet been developed for your situation.
 Jenny L.  posted on Wednesday, June 05, 2013 - 3:10 am
Thank you for your advice. I'm using version 7 so it should not be the concern. May I ask what might be some reasons why "CI and probability have not yet been developed"? Is it possibly because the lower bound is 0 and the upper bound is also very close to 0 and thus the CI was not displayed? (I had a chi square(df=2)=.01, CFI=1.000, TLI=1.029). Thank you for your help!
 Linda K. Muthen posted on Wednesday, June 05, 2013 - 12:07 pm
No one has taken the time to research the proper CI and probability for all situations.
 Li posted on Thursday, December 19, 2013 - 12:55 pm
Drs. Muthen,
I did a factor analysis with categorical outcomes using Mplus 7, and the reported confidence interval is 90%. I was wondering why Mplus does not report a 95% CI because that's more conventional. I ask this question because a reviewer of my article asked why I reported 90% CI instead of 95%. I sense there is probably a reason behind the decision made by Mplus.
Thanks for your explanation.
Li
 Bengt O. Muthen posted on Thursday, December 19, 2013 - 4:40 pm
Please send that output to Support.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: