Error messages in path analysis PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 James Hodge posted on Tuesday, February 11, 2014 - 2:41 pm
Hello,

I'm trying to run a path analysis and I'm getting the error messages below. Any thoughts?

1) Why is it saying my N is zero?
2) What symbol is invalid in "HEt1"?

Thanks!
-James

________

Mplus VERSION 6.12
MUTHEN & MUTHEN
02/11/2014 11:37 AM

INPUT INSTRUCTIONS

TITLE: PEZ path analysis

DATA: FILE IS pez-data-for-path-analysis.csv;
NOBSERVATIONS IS 180;

VARIABLE: NAMES ARE id HEt1 MDt1 BDIt1 HEt2 MDt2 BDIt2 HEt3 MDt3 BDIt3;
USEVARIABLES ARE BDIt1 BDIt2 BDIt3 HEt1 HEt2 HEt3;

ANALYSIS: TYPE IS GENERAL;
ESTIMATOR IS ML;

MODEL: BDIt3 ON BDIt2;
BDIt3 ON HEt2;
HEt3 ON HEt2;
HEt3 ON BDIt2 (1);
BDIt2 ON BDIt1;
BDIt2 ON HEt1;
HEt2 ON HEt1;
HEt2 ON BDIt1 (1);
BDIt2 WITH HEt1;

OUTPUT: SAMP; STAND; RES;

*** ERROR
The number of observations is 0. Check your data and format statement.
Data file: pez-data-for-path-analysis.csv
*** ERROR
Invalid symbol in data file:
"HEt1" at record #: 1, field #: 2
 Linda K. Muthen posted on Tuesday, February 11, 2014 - 4:30 pm
Open the data file in the Mplus editor. Delete the invalid character at the beginning of the data set. Save the data.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: