GFI vs. CFI PreviousNext
Mplus Discussion > Structural Equation Modeling >
 Bill posted on Monday, July 28, 2008 - 7:34 pm
I was running Structural Equation Modeling and found the results a bit tricky. The questions are:

1) if I choose the estimation method as 'Maximum Likelihood', then the model fit indexes are: CFI = 0.92, GFI = 0.81;

2) if I choose the estimation method as 'Generalized Least Squares', then the model fit indexes are: CFI = 0.64, GFI = 0.83;

3) if I choose the estimation method as 'Unweighted Least Square', then GFI = 0.97.

As I understand that to get an acceptable model, CFI needs to be larger than 0.90. Normally we expect GFI is close to CFI. But here GFI and CFI differ significantly. Where is my problem?

Please teach.
 Bengt O. Muthen posted on Tuesday, July 29, 2008 - 9:41 am
I think you mean TLI, not GFI (which Mplus does not report). Typically, a CFI > 0.95 is needed for a reasonable model fit. 0.92 is not sufficient. CFI and TLI can differ quite a lot for ill-fitting models.
 Bill posted on Tuesday, July 29, 2008 - 1:14 pm
What are the main factors that lead to lower index values (e.g CFI, GFI)? Reliability?

In my model, all the reliabilities are larger than 0.80.

Can anyone plz recommend a technical book on SEM to find out the factors that result in low index values?
 Linda K. Muthen posted on Wednesday, July 30, 2008 - 7:32 am
The reasons for poor fit indices may be due to many things. One important one is model misspecification.

I would suggest posting your question on SEMNET where you may get more suggestions for readings.
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message