Comparison of Mplus results with R & ... PreviousNext
Mplus Discussion > Multilevel Data/Complex Sample >
Message/Author
 Mariya Shiyko posted on Monday, September 22, 2008 - 8:32 pm
Hello,
I am working with longitudinal data where observations per individual range from 3 to 30 days. I am conceptualizing my model similar to example 9.16 of your user's guide with a count variable as an outcome. Ultimately, I would like to do GMM (& introduce latent growth classes), but I started by trying to replicate analysis of a mixed-effects model I performed in R with lme4 package).

Below is my syntax:
VARIABLE: ...
CLUSTER = SubjID;
COUNT = allSmo;
WITHIN = SRSday;
BETWEEN = FagerC numQA SEMeanC;
ANALYSIS: TYPE = TWOLEVEL RANDOM;
MODEL: %WITHIN%
sl | allSmo ON SRSday;
%BETWEEN%
allSmo ON FagerC;
sl ON numQA SEMeanC;
allSmo WITH sl;

When I ran this model, the results are very different from those I got in R and HLM (Raudenbush): parameter estimates, although have similar directionality, are different in magnitude; all model fit indices are very different. Also, user's guide says that the intercept is set as random automatically. I am not sure that it was the case in my model, since the # of continuous latent variables are listed as 1 (I would think that both the intercept and the slope are latent continuous). Also, residual variance was estimated only for the slope, not the intercept. What do I need to change? Thank you very much for your attention!
 Bengt O. Muthen posted on Tuesday, September 23, 2008 - 6:18 am
You should get exactly the same results as other programs. Please send your input, output, data, and license number to support@statmodel.com.
 Xu, Man posted on Saturday, October 04, 2008 - 6:53 am
could it be due to rounding errors? i also found the results from Mplus and MLwin are often very slightly different.
 Bengt O. Muthen posted on Saturday, October 04, 2008 - 12:05 pm
Slight differences are often due to slightly different convergence criteria - which can be sharpened to move the programs' results closer to each other.
 Lois Downey posted on Wednesday, July 07, 2010 - 5:16 pm
In my study of repeated measures within patients, I'm having the same difficulty Mariya Shiyko noted in the post of 22 Sep 2008. My results from HLM and Mplus two-level give somewhat different estimates for fixed effects (6.609 vs. 6.357, respectively, for the intercepts; -0.005 and -0.004 for the slopes) and also different estimates for some variance components (5.249 vs. 3.483 for intercepts; both programs showing <0.001 for slope variance; residual variances of 2.249 vs. 2.291). Deviances were also slightly different (8649.572 in HLM, compared with LL of -4321.733 in Mplus).

I also notice that HLM indicates that it is estimating only 4 parameters, whereas Mplus shows 5 free parameters. Is this related to the fact that although HLM estimates residual variance, it does not compute its significance, whereas Mplus does?

You indicated to Mariya that the results from the two programs should match exactly. However, I wonder whether in your investigation of the problem Mariya reported, you discovered some difference between the computation methods used by HLM vs. Mplus that would account for differences such as these.

Thank you.
 Linda K. Muthen posted on Wednesday, July 07, 2010 - 5:27 pm
Differences seen are usually due to using different estimators. Maximum likelihood should be used in both. Also, if the model does not have the same parameters, the results will differ. You would need to see which parameter differs between the two programs and change one of them so that you are estimating the same model. Differences will be seen also if the data are different, for example if there are missing data and one program uses listwise deletion and the other doesn't. Other than that, with the same data, model, and estimator, you will get the same results. If you can't figure it, please send the HLM and Mplus outputs along with your license number to support@statmodel.com.
 Jamie Vaske posted on Monday, August 23, 2010 - 5:15 pm
I am testing an unconditional model with a binary variable. I have noticed that the significance test of the variance component in HLM gives me a different substantive result than the significance test of the variance result in MPLUS. I use the same estimator (ML) and receive similar estimates of the coefficients and standard errors. However, the chi-square test of HLM shows a significant variance estimate (p = .043), while the z-test in MPLUS suggests non-significant variance estimate (p = .146). Is there a reason to use the z distribution (with a binary variable) rather than the chi-square? Thank you for you assistance!
 Linda K. Muthen posted on Tuesday, August 24, 2010 - 8:14 am
z squared should be equal to the chi-square value. If you want further information on the differences you see, send the HLM and Mplus outputs along with your license number to support@statmodel.com.
 Linda K. Muthen posted on Tuesday, August 24, 2010 - 10:04 am
Thanks for sending the outputs. You need to sue maximum likelihood in HLM to compare to Mplus.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: