Error Message - 2-Level EFA PreviousNext
Mplus Discussion > Multilevel Data/Complex Sample >
Message/Author
 Nidhi Kohli posted on Friday, October 14, 2011 - 6:51 pm
I am getting the following error message when I try to run the code for two-level EFA model.

*** ERROR in VARIABLE command
On the USEVARIABLES list, variables from the NAMES list must come before
all new variables created using the DEFINE command. The variables(s)
violating this order are: E

This message does not amke sense because there is no DEFINE command in the code.

Here is the code that I used:

TITLE:...;
DATA =...;
VARIABLE:
NAMES = visitid topicode vlink expect repeat priority agenda social adhere pimpact dimpact empathy psychval
dinform solicit lsolicit rsolicit msolicit lreason rreason mreason lcomp rcomp mcomp lalter ralter
malter lplan rplan lcost rcost mcost lguide mguide rguide weight monitor smoke diet exercise idmlisten
idmmhlis idmrespect idmmhres lfeas rfeas mfeas idmshare idmmhshare;

USEVAR = visitid vlink expect repeat priority agenda social adhere pimpact dimpact empathy psychval
dinform solicit lsolicit rsolicit msolicit lreason rreason mreason lcomp rcomp mcomp lalter ralter
malter lplan rplan lcost rcost mcost lguide mguide rguide weight monitor smoke diet exercise idmlisten
idmmhlis idmrespect idmmhres lfeas rfeas mfeas idmshare idmmhshare;

...
 Linda K. Muthen posted on Friday, October 14, 2011 - 8:10 pm
Please send the output and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: