Result of Latent Profile Analysis PreviousNext
Mplus Discussion > Latent Variable Mixture Modeling >
 Yu Bi posted on Saturday, November 16, 2013 - 3:27 pm
I ran a LPA to explore the latent classes of risk factors of child depression. LPA result indicated a five class solution. However, when I try to look at the characters of each class, I encountered a difficulty. Results showed

Estimate S.E. Est./S.E. P-Value

Latent Class 1

Y3HOME -6.411 1.160 -5.529 0.000
Y3NCTOT -6.888 1.008 -6.833 0.000
Y3CESD -1.221 1.193 -1.024 0.306
Y3PSI -2.245 2.649 -0.848 0.397
Y3EXT -1.408 1.423 -0.990 0.322

I am very confused about this result because none of my class indicator variables contains negative value. Thus, it is very confusing that the estimate of means of those variables are negative. Could anyone tell me what is going on? In addition, I noticed that the results also provide "STANDARDIZED MODEL RESULTS" which also contains negative values. Should I report the standardized results or not? Thanks very much!
 Bengt O. Muthen posted on Saturday, November 16, 2013 - 6:02 pm
Please send your output to Support.
 Yu Bi posted on Sunday, November 17, 2013 - 11:09 am
Hello Dr. Muthen,the output is too large to post here, can I send it to you by email? Thanks!
 Linda K. Muthen posted on Sunday, November 17, 2013 - 11:19 am
Please send the output and your license number to
 Catherine Rice posted on Monday, March 06, 2017 - 10:59 am
Hi Dr. Muthen,
I am running into a similar problem. I am using counts as the indicator variables in an LPA, and results indicated a 3-class solution. However, when I look at the mean estimates for each class, many are negative, and I'm not sure how to interpret them, as none of the indicator variables are below 0. Can you explain this? In addition, I have one variable where the mean estimate was approaching an extreme value and was set at -15. From what I've read on previous threads, this indicates that this indicator variable is 0 for this class with a probability of 1. Is that correct? Thank you for your help!
 Bengt O. Muthen posted on Monday, March 06, 2017 - 6:04 pm
The estimates are in the log metric. Use exp(estimate) to get to the count mean metric.

About the -15 value it sounds like you are using a zero-inflated model where you have a binary DV part. If you get -15 for it means you don't need the inflation part.

If this doesn't help, send output and license number to Support.
 Catherine Rice posted on Tuesday, March 07, 2017 - 8:16 am
This is very helpful, thank you for your quick reply!
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message