Reading data from ascii file PreviousNext
Mplus Discussion > Growth Modeling of Longitudinal Data >
Message/Author
 Anonymous posted on Tuesday, August 10, 2004 - 3:40 pm
I have suddenly started to experience a bizarre problem, where MPlus will only read half the cases in my data file. I have tried endless different ways of trying to discover why this is happening but nothing seems to work. Any ideas please as it is driving me crazy?!

Patrick
 Linda K. Muthen posted on Friday, August 13, 2004 - 9:53 pm
You would need to send the data and input to support@statmodel.com for me to say for sure. But the most likely cause is that you have blanks in the data and are reading free format. Or that you do not realize that the default is listwise deletion of any case that has a missing value on one or more analysis variables.
 robertav posted on Thursday, May 29, 2008 - 2:57 pm
I have a problem in reading data file .txt to run an EFA.
I think I wrote everything in the correct way, but when I define some categorical variables in the output I see that the program is reading "more" categories than the existing categories.

VARIABLE:
NAMES ARE
Cod_Cors cod_cdl Cod_Doc
D3 D4 D6 D7 D8 D9 D10 D11 D22 D23
cid
d3_a d4_a d6_a d7_a d8_a d9_a d10_a d11_a d22_a d23_a
d3_b d4_b d6_b d7_b d8_b d9_b d10_b d11_b d22_b d23_b
d3_c d4_c d6_c d7_c d8_c d9_c d10_c d11_c d22_c d23_c;

USEVARIABLES ARE
d3_b d4_b d6_b;

CATEGORICAL ARE
d3_b d4_b d6_b ;
MISSING are
all(999);


OUTPUT (selected):

D6_B
Category 1 0.141
Category 2 0.366
Category 3 0.493
Category 4 0.000
Category 5 0.000


Do you know what is going on?
Thanks,
roberta
 Linda K. Muthen posted on Thursday, May 29, 2008 - 3:10 pm
Please send your input, data, output, and license number to support@statmodel.com. You are most likely reading the data incorrectly.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: