Error Message on Missing Data Estimator PreviousNext
Mplus Discussion > Missing Data Modeling >
Message/Author
 Angela Henneberger posted on Tuesday, February 21, 2012 - 11:41 pm
Dear Muthens,

Running a regression model with an N of 622 and about 10% missing across waves. My input syntax is below. When I run using ESTIMATOR = ML or ESTIMATOR = MLR, I get the following error message:

THE MODEL ESTIMATION DID NOT TERMINATE NORMALLY DUE TO AN ILL-CONDITIONED
FISHER INFORMATION MATRIX. CHANGE YOUR MODEL AND/OR STARTING VALUES.
THE MODEL ESTIMATION DID NOT TERMINATE NORMALLY DUE TO A NON-POSITIVE
DEFINITE FISHER INFORMATION MATRIX. THIS MAY BE DUE TO THE STARTING VALUES
BUT MAY ALSO BE AN INDICATION OF MODEL NONIDENTIFICATION. THE CONDITION
NUMBER IS 0.141D-12.
THE STANDARD ERRORS OF THE MODEL PARAMETER ESTIMATES COULD NOT BE
COMPUTED. THIS IS OFTEN DUE TO THE STARTING VALUES BUT MAY ALSO BE
AN INDICATION OF MODEL NONIDENTIFICATION. CHANGE YOUR MODEL AND/OR
STARTING VALUES. PROBLEM INVOLVING PARAMETER 13.

The only way I can get the model to run is to use ESTIMATOR = BAYES. Is it okay to use BAYES for my regression model, or do you have another though on the best way to handle this error?

Thanks,

Angie

MISSING ARE ALL (-9999);

CATEGORICAL ARE x y z;

ANALYSIS:
ESTIMATOR = ML;
INTEGRATION = montecarlo;

MODEL: A ON x y z K L M N I1 I2 I3 I4 I5 I6 I7;

K;
L;
M;
N;
I1;
I2;
I3;
I4;
I5;
I6;
I7;
 Bengt O. Muthen posted on Wednesday, February 22, 2012 - 12:30 am
To more clearly see this, please send to support. Also state if any of the IVs are dichotomous.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: