Categoric simplex models PreviousNext
Mplus Discussion > Categorical Data Modeling >
Message/Author
 Anonymous posted on Monday, July 19, 2004 - 7:08 pm
I am having trouble with the estimation of a four-wave simplex model using categoric variables. I'm sorry to ask such a general question, but do I have the code right? When I run the same model treating the data as continuous, it works fine. I'm trying to sort out whether I have a problem with my data or my code. When I run the code below, I get the following error:

THE STANDARD ERRORS OF THE MODEL PARAMETER ESTIMATES COULD NOT BE
COMPUTED. THE MODEL MAY NOT BE IDENTIFIED. CHECK YOUR MODEL.
PROBLEM INVOLVING PARAMETER 12.


The code:

DATA: FILE IS ma1.dat;
VARIABLE: NAMES ARE x1-x4;
CATEGORICAL ARE x1-x4;
MISSING ARE .;
ANALYSIS: TYPE = H1 MISSING;
PARAMETERIZATION=THETA;
ESTIMATOR=WLSMV;
MODEL: [x1$1 x2$1 x3$1 x4$1] (2);
[x1$2 x2$2 x3$2 x4$2] (3);
[x1$3 x2$3 x3$3 x4$3] (4);
[x1$4 x2$4 x3$4 x4$4] (5);
t1 BY x1;
t2 BY x2;
t3 BY x3;
t4 BY x4;
x1 (1);
x2 (1);
x3 (1);
x4 (1);

t2 ON t1;
t3 ON t2;
t4 ON t3;

OUTPUT: SAMP STAND tech1;
 Linda K. Muthen posted on Monday, July 19, 2004 - 9:40 pm
You have four factors with single indicators. Just get rid of these and do your regressions using the x variables. With a single group analysis, the residual variances of the categorical variables are fixed to zero. They can only be part of a multiple group or growth model.
 Anonymous posted on Tuesday, July 20, 2004 - 5:23 pm
Actually, in my case, it is the partitioning of the variance that I am most interested in. I should have mentioned that x1-x4 are the same indicators measured longitudinally. I think that what is missing from my code is a scaling of the true-score variance. Adding the following line seems to yield sensible results:

t1 @ 1;
 Linda K. Muthen posted on Tuesday, July 20, 2004 - 10:58 pm
If this is a growth model, then fixing the first residual variance to one is the way to identify the model.
 Ryan McCammon posted on Friday, March 18, 2005 - 2:37 pm
Indeed, this is not a growth model, but a four wave autoregressive model. That is, I have a single item measured longitudinally in a panel study. I would like to estimate a model like Wiley & Wiley (1970) using categoric variables.

I have estimated such models using the THETA parameterization and constraining the thresholds equal across occasions of measurement.

I would then like to divide my sample into groups based on birth cohort and estimate the model again in a multiple group framework. This approach often fails. In attempting to estimate these models, I have constrained the thresholds to be equal both across occasions of measurement and across groups. Is this later constraint necessary? What I am really interested in is knowing if the ratios of true score variance to total variance (reliability) varies between birth cohorts. I think that the varying observed distributions between groups is the source of my difficulty.
 Ryan McCammon posted on Friday, March 18, 2005 - 5:47 pm
In the multiple group framework, I attempt to estimate two models, 1) a fully-constrained model with all parameters equal across groups (H0), and 2) a model where the groups are estimated independently, save for the equal threshold constraint within and between groups (H1). It is this latter model that often fails. This failure also seems to be related to the number of response categories, such that dichotomies fail to yield a proper solution more often than do items with a larger number of observed levels.
 Linda K. Muthen posted on Friday, March 18, 2005 - 6:40 pm
I think the only way to understand what you are experiencing is to see the two ouptputs -- constrained and non-constrained. Can you send them along with your license number to support@statmodel.com. There are many issues that could be coming into play.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: