# of Free / Estimated Parameters in M... PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
Message/Author
 WRK posted on Tuesday, July 03, 2012 - 7:15 pm
Hello everyone,

Today I was conducting a method factor model to test for common method bias. I ran the model in Mplus and then in AMOS to check my results. Both models produced the exact same parameter estimates, df, chi-square, etc. However, the two programs report a different number of free parameters.

To isolate the issue, I broke my model down to a simple CFA with 1 latent factor and 8 observed variables. In AMOS and in my head, that results in 16 free / estimated parameters. Hence 7 measurement relationships (8th is fixed @1) + 8 residual variances + 1 variance = 16.

However, Mplus says there are 24 free parameters. The difference between Mplus and AMOS is 24-16 = 8 (i.e. the number of observed variables I am working with).

Does anyone know why Mplus is getting 24 free parameters? What am I missing here? It's been a long day. Is Mplus counting the intercepts?

Thanks so much!

ANALYSIS:
TYPE IS GENERAL;
ESTIMATOR IS ML;
ITERATIONS = 1000;
CONVERGENCE = 0.00005;

VARIABLE:
NAMES ARE
eo1 eo2 eo3 eo4 eo5 eo6 eo7 eo8 eo9 eo10 eo11
eo12 eo13 eo14 eo15 eo16 eo17 eo18 pos1 pos2 pos3 pos4
pos5 pos6 pos7 pos8 es1 es2 es3 es4 ee1 ee2 ee3 ee4 ee5;
USEVARIABLES ARE
pos1 pos2 pos3 pos4 pos5 pos6 pos7 pos8

MODEL:
POS BY pos1@1 pos2 pos3 pos4 pos5 pos6 pos7 pos8;


OUTPUT: STANDARDIZED;
 Linda K. Muthen posted on Tuesday, July 03, 2012 - 7:55 pm
The difference is likely that intercepts are being estimated in Mplus and not in Amos.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: