I can't get the list function to work... PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
 Jon Heron posted on Saturday, March 06, 2010 - 8:56 am
Dearest Mplus,

I've never been able to get the list function to work when constraining a set of parameters + think it's about time I worked out why.

This is my current model. I want to constrain factor loadings across genders.

f by a_happ* c_reli e_exci b_bore d_hope;

model gender:
f by a_happ* c_reli e_exci b_bore d_hope (1-5);
f@1 (eqvar) ;
[f] ;
f by a_happ* c_reli e_exci b_bore d_hope (1-5);
f@1 (eqvar) ;
[f] ;

However I am given the error:
" There are more equality labels given than there are parameters.
Some equality labels will not be used.
Equality: 1-5"

and I end up with a model in which ALL loadings are constrained to the same value.

I've tried in the past with a variety of models + have had no success :-(

Any ideas gratefully recieved

thanks, Jon
 Linda K. Muthen posted on Saturday, March 06, 2010 - 10:45 am
The list of labels can be used only with a list of parameters, for example,

f by a_happ* (1)
c_reli - d_hope (2-5);

if the variables are in order.

I don't think a_happ can be included in the list because of the asterisk.
 Jon Heron posted on Monday, March 08, 2010 - 1:52 am
Ah thanks Linda, that could well be it.
The variables are ordered in my datafile
alphabetically but are ordered in the model by positive/negative valence

i'll give that a go
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message