CFI/ TLI not computed due to converge... PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 Suzanne posted on Monday, January 16, 2006 - 4:56 pm
Hello-

I have been getting an error message that says "CFI and TLI were not computed due to convergence problems in the baseline model." I get this message whether I specify the whole model or just the measurement model. The model appears to be identified, and MPlus gives me estimates for the other fit indices. I also tried running it with type=general instead of type=complex and I got the same message.

The code I am using is below. If you have any suggestions about what the problem could be, I would greatly appreciate it.
Thank you.

variable:

NAMES ARE stuid schid strat psu bystuwt f1pnlwt nwintinv schluse g10math g10read sex sturace black asian hispanic ses expflag mathflag hmwkchec hmwkhelp disrc discs discex discap dohmwk attn hardwk gencomm hmwkscle dscsscle g12math g12exp dropout reten;

USEVARIABLES ARE stuid strat psu f1pnlwt nwintinv schluse g10math hmwkchec hmwkhelp disrc discs discex discap dohmwk g12math;

CLUSTER is psu;
WEIGHT is f1pnlwt;

MISSING IS .;

analysis:
type=complex;

model:
discuss by discs discex discap;
homework by hmwkchec hmwkhelp;
homework with discuss;
nwintinv on schluse;
homework on nwintinv;
homework on g10math;
discuss on nwintinv;
discuss on g10math;
g12math on nwintinv;
g12math on homework;
g12math on discuss;
g12math on g10math;
 Linda K. Muthen posted on Monday, January 16, 2006 - 6:17 pm
It is not the analysis model that is not converging. It is the baseline model that is used to compute CFI and TLI. If you are not using Version 3.13, please do so. If you are, send your input, data, output, and license number to support@statmodel.com and I will see if I can help you.
 Suzanne posted on Friday, January 20, 2006 - 12:54 am
Thanks for your response. I was able to solve the above problem.

I am encountering another problem, however. When I run the model, it appears to be identified and it runs with no problems. But when I try to run a multi-group model with a constrained and unconstrained model, it won't compute the chi square and tells me that the model may not be identified. Why would this be happening? My code for the unconstrained model is below. Thank you!

USEVARIABLES ARE psu f1pnlwt hmwkchec hmwkhelp discs discex discap byp73yn schluse g10math g12math;

CATEGORICAL IS byp73yn;

GROUPING IS sex (0=male 1=female);

CLUSTER is psu;
WEIGHT is f1pnlwt;

MISSING IS .;

analysis:
type=complex;

model:
discuss by discs discex discap;
homework by hmwkchec hmwkhelp;
homework with discuss;
discap with discex;
byp73yn on schluse;
byp73yn on g10math;
homework on byp73yn;
homework on g10math;
discuss on byp73yn;
discuss on g10math;
g12math on byp73yn;
g12math on homework;
g12math on discuss;
g12math on g10math;

model male:
discuss by discs discex discap;
homework by hmwkchec hmwkhelp;
homework with discuss;
discap with discex;
byp73yn on schluse;
byp73yn on g10math;
homework on byp73yn;
homework on g10math;
discuss on byp73yn;
discuss on g10math;
g12math on byp73yn;
g12math on homework;
g12math on discuss;
g12math on g10math;

output: standardized modindices (10);
 Linda K. Muthen posted on Friday, January 20, 2006 - 12:08 pm
You should not mention the first factor indicators in the group-specific MODEL command. This frees the parameter which should be fixed to zero.

Questions related to the use of the Mplus commands should be sent to support@statmodel.com along with your license number.
 Jeremiah Schumm posted on Thursday, February 14, 2008 - 6:44 pm
Dr. Muthen,

I am using Mplus v 4.1. I am receiving the same error message as "Suzanne" posted on 1/16/06. Specifically, the error message states "CFI and TLI were not computed due to convergence problems in the baseline model." The analysis model converged appropriately. Your help is appreciated. I am including the analysis and model syntax below.

ANALYSIS:
TYPE IS GENERAL MISSING H1;
ESTIMATOR IS MLR;
ITERATIONS = 50000;
CONVERGENCE = 0.0001;
H1ITERATIONS = 50000;
H1CONVERGENCE = 0.0001;
COVERAGE = 0.10;

MODEL:
mfvl25c2 WITH fmvl25c2 ;
mfvl25c3 WITH fmvl25c3 ;
ETOHtf2y ON ETOHtf1y ETOHtm1y ;
ETOHtm2y ON ETOHtf1y ETOHtm1y ;
mfvl25c2 ON mfvl25c1 fmvl25c1 ETOHtf1y ETOHtm1y ;
mfvl25c3 ON fmvl25c2 mfvl25c2 ETOHtf2y ETOHtm2y ;
fmvl25c2 ON mfvl25c1 fmvl25c1 ETOHtf1y ETOHtm1y ;
fmvl25c3 ON fmvl25c2 mfvl25c2 ETOHtf2y ETOHtm2y ;

MODEL INDIRECT:
mfvl25c3 IND ETOHtf1y ;


OUTPUT: MODINDICES STANDARDIZED PATTERNS TECH4;
 Linda K. Muthen posted on Thursday, February 14, 2008 - 8:22 pm
The message means that the baseline model did not converge. Information from the baseline model is needed to compute CFI and TLI so they cannot be computed. If you have further questions, please send your input, data, output, and license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: