Error Undefined variable used in tran... PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 janelle wells posted on Thursday, September 06, 2012 - 8:25 am
Linda,
I continue to receive this error message Undefined variable used in transfromation: ACOM. I am using Preacher's mplus code for a moderated mediator and I've defined my new variable (AcomXJemb), listed at the end of my USERVARIABLES list, but I continue to receive the error.

*** ERROR
Undefined variable used in transformation:
ACOM

Here is an abbreviated syntax:

USEVARIABLE ARE
(a list of all my items plus the interaction variable listed below)
AcomxJemb;
Missing = all(-99);

DEFINE:
AcomxJemb = Acom*jemb;

ANALYSIS: bootstrap = 5000;

model:
Factor1 by TransF1 TransF2 TransF6 TransF9 TransF11
TransF12 TransF13 TransF14 TransF16;
Jemb by JembL58 JembL60 JembL61 JembL62;
Acom by AcomL64 AcomL66 AcomL68;
TurnO by TurnOL69 TurnOL71 TurnOL72 TurnOL73;
JSB by JSBL75 JSBL76 JSBL77 JSBL78 JSBL79;

JSB on Acom (b1)
Factor1
Jemb
AcomxJemb (b3);
Acom on Factor1 (a1);
Jemb with Acom;
AcomXJemb with Acom;

MODEL CONSTRAINT:
new (ind wmodval);
wmodval = 3.75;
ind= a1*(b1+b3*wmodval);

output:
cinterval (bcbootstrap);


Any assistance you could offer, would be great.
Thanks,
Janelle
 Linda K. Muthen posted on Thursday, September 06, 2012 - 10:09 am
Please send your output and license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: