Nonpositive Trace PreviousNext
Mplus Discussion > Multilevel Data/Complex Sample >
Message/Author
 Anthony Coy posted on Thursday, October 06, 2011 - 4:38 pm
Hello!

I am working on examining partner effects (similar to the actor-partner interdependence model) using observed categorical variables and interactions of those variables. Note: I created my interaction terms in the design statement. When I run the model, it says that it terminated normally and provides me with the standard output but doesn't provide the chi-squared, CFI, TLI or RMSEA statistics with the message that, "ROBUST CHI-SQUARE IS NOT DEFINED DUE TO NONPOSITIVE TRACE." This discussion board is the only place I've seen a nonpos trace mentioned and I'm not sure what it means. Any help you could provide would be greatly appreciated!

Thanks!
 Tihomir Asparouhov posted on Friday, October 07, 2011 - 3:52 pm
Formula (106) in the technical appendices is where the problem occurs. See http://statmodel.com/download/techappen.pdf.

These formulas are asymptotic and can run into such problems for small sample sizes. There may be other things that cause this problem - perhaps sever model misspecification.

One way to proceed is to change the estimator. You can try estimator=ulsmv or wls.

You can send your example to support@statmodel.com for possible further insights.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: