LCA convergence problem PreviousNext
Mplus Discussion > Latent Variable Mixture Modeling >
Message/Author
 April posted on Thursday, January 26, 2006 - 8:29 pm
Dear Drs. Muthen,

I have a cross-sectional data on injection risk behavior. I'm trying to examine the distribution of those risk behaviors in unknown classes and what covariates may affect that. Before adding any covariate into the model, I ran an analysis with 6 binary indicators (which were combined from 18 risk items) and 3 classes.

The input is attached below. First, the warning says "All variables are uncorrelated with all other variables within class." Then, it says, unperturbed, as well as 2 perturded, starting value runs did not converge, the model estimation did not terminate normally due to a change in the class counts during the last E step.

I'm wondering if this could be due to a sample size problem, or LCA is not an appropriate model by the nature of the data, and if any solutions?

I appologize if this kind of problem had already been discussed before. I searched but just didn't find it. Thank you very much.


INPUT INSTRUCTIONS

DATA: FILE IS F:\mplus419.txt;

VARIABLE:
NAMES ARE k9i1_2 k10i1_2 k11i1_2 k12i1_2 k17i1_2 k18i1_2 k20i1_2 k22i1_2 k24i1_2 k26i1_2 k28i1_2 k30i1_2 k31i1_2 k32i1_2 k33i1_2 k34i1_2 k35i1_2 k36i1_2 k37i1_2 k38i1_2 inj1i1 inj2i1 inj3i1 inj4i1 inj5i1 inj6i1 inj7i1 inj8i1 inj9i1;

USEV = inj3i1 inj4i1 inj6i1 inj7i1 inj8i1 inj9i1;

CLASSES = C(3)

CATEGORICAL= inj3i1 inj4i1 inj6i1 inj7i1 inj8i1 inj9i1;

MISSING ARE inj3i1 inj4i1 inj6i1 inj7i1 inj8i1 inj9i1(9999);

ANALYSIS: TYPE = MIXTURE;
MITERATIONS = 1000;

OUTPUT: TECH8;


Thanks.
 Linda K. Muthen posted on Thursday, January 26, 2006 - 8:48 pm
This type of data dependent question is more appropriate for Mplus support. Please send your input, data, output, and license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: