Fit ARMA model in latent growth mod... PreviousNext
Mplus Discussion > Growth Modeling of Longitudinal Data >
Message/Author
 sunny shi posted on Thursday, February 05, 2009 - 5:17 pm
I am trying to fit first order ARMA(1,1)(autogressive and moving average)model to the latent growth modeling with time invariant covariate. There are four time points with outcome variable measured as y1,y2,y3,y4 and time nvariant covariate x. The ARMA (1,1) model looks like the following:
y1 = 1*INT + 0*slope+ error1,
y2 = 1*INT + 1*SLP + ARlag1*y1 + MAlag1* error1+ error2,
y3 = 1*INT + 2*SLP + ARlag1*y2 + MAlag1* error2+error3,
y4 = 1*INT + 3*SLP + ARlag1*y3 + MAlag1 error3+ error4,
INT = Mean_INT+ beta1*X +disturbance1,
SLP = Mean_SLP+ beta2*x+disturbance2;

The sample Mplus program for the model statment is:

MODEL:
i BY t1-t4@1;
s BY t1@0 t2@1 t3@2 t4@3;
[i* s*];
[t1-t4@0];
i* s*;
t1-t4*;
i with s*;
i s on x ;

However, how could I specify the error term in the model statement in Mplus?
Look forward to your early reply.
 Bengt O. Muthen posted on Thursday, February 05, 2009 - 7:20 pm
Your residual variances are

time 1: V(error1)
time 2: MAlag1^2*V(error1)+V(error2)
etc

which means that you have a structure for these residual variance parameters. I think you can handle that using the Constraint= option with MAlag1^2 in the VARIABLE command together with Model Constraint - see the User's Guide.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: