Factorial Invariance & missing data PreviousNext
Mplus Discussion > Missing Data Modeling >
Message/Author
 Bit na, LEE posted on Sunday, August 25, 2013 - 2:49 pm
Dear Linda,

I hope that all things are doing well.
I am working on factorial Invariance between a full version test (B test) and a short version test (A test) - A test has been developed as a short version of B test). Therefore, since A test is a short version, there are some missing data in A test data set. However, Mplus could not read the missing data when conducting factorial invariance analysis � which the syntax said as follows:
*** WARNING in ANALYSIS command
MODEL=NOMEANSTRUCTURE is not allowed in conjuction with TYPE=MISSING.
Request for MODEL=NOMEANSTRUCTURE will be ignored.

Would you please give me any advice to solve this problem? If you want, I could send the original data set and code.

Thank you so much
Sincerely,
Bitna
 Linda K. Muthen posted on Sunday, August 25, 2013 - 5:39 pm
The model must contain means when TYPE=MISSING is used. This is not a problem. A model with unstructured means is the same as a model with no means.
 Bit na, LEE posted on Sunday, March 02, 2014 - 11:11 am
Hi, Linda

I have one more question.
So, when missing is defined as "DEFINE: IF (Y3 EQ 0) THEN Y3=_MISSING", "MODEL=NOMEANSTRUCTURE "is also not allowed?
 Linda K. Muthen posted on Sunday, March 02, 2014 - 12:52 pm
Tht is correct. A model with unstructured means yields the same results as a model with no means.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: