Factor Invariance Over Time PreviousNext
Mplus Discussion > Categorical Data Modeling >
 Anonymous posted on Thursday, April 12, 2001 - 1:42 pm
How do I test for factor pattern invariance over time in Mplus? I want to see if the two dimensional structure holds at two follow up time points. Each dimension is measured by 2-3 categorical indicators. Should I set it up in a SEM type of model with correlated errors over time? If so, how do I correlate errors in M-Plus?
 Bengt O. Muthen posted on Sunday, April 15, 2001 - 12:13 am
You set it up as a CFA. Here is an example that gives the idea for 2 binary indicators at 2 time points, imposing invariant thresholds and loadings, while allowing scale factors to differ across time (see also User's Guide):


!time 1

f1 BY y11
!first indicator loading is
!fixed at one by default

y12 (1);
[y11$1] (2);
[y12$1] (3);

!time 2

f2 by y21
y22 (1);
[y21$1] (2);
[y22$1] (3);
{y21 y22};

Correlated errors are simply handled by e.g.

y11 with y21;
 RuoShui posted on Wednesday, April 02, 2014 - 3:06 am
Dear Bengt,

I was reading your above posting. You said "allowing scale factors to differ across time " . In the UG, it says to fix scale factors at one in for one time points and free in the other. Also, factor means will be fixed at zero for one time point and free in the other. Could you please let me know which is the correct way?

i guess I don't quite understand the purpose of fixing scale factor and factor means for one time but free in others.

Thank you very much!
 Linda K. Muthen posted on Wednesday, April 02, 2014 - 5:21 pm
Scale factors must be fixed to one at one time point and factor means must be fixed to zero at one time point. This is required for the model to be identified.
 RuoShui posted on Wednesday, April 02, 2014 - 7:24 pm
Thank you very much Dr. Muthen.

When I fitted a linear growth model, the model would not converge if I used the scalar invariance model, in which I specified [f1@0 f2 f3]. Only after I removed this syntax line did the model converge. Is it because the linear growth model is estimating based on factor means, I should not specify them?

Thank you!!
 Linda K. Muthen posted on Wednesday, April 02, 2014 - 9:28 pm
Please send the output and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message