EFA plus monte carlo question PreviousNext
Mplus Discussion > Exploratory Factor Analysis >
Message/Author
 Guy Cafri posted on Friday, December 12, 2008 - 7:21 pm
Hi,
I am running an EFA with 19 factors and 127 items (a lot I know) and missing data. I want to handle the missing data using FIML and so am using ML estimation. The program took a while to run, and although it said input terminated normally in the output statement, there was no output thereafter. Can you give any suggestions about what I should?

Another question I have that is unrelated has to do with the monte carlo facility.
I am just getting started using this and had a question about the way in which to set up the simulation. For regression
example 3.1 I did the following:


MODEL POPULATION:
[x1-x1@0];
x1-x3@1;
y1@1;
[y1@0];
x1 with x3*.5;
y1 with x1*.3;
y1 with x3*.3;

MODEL:
y1 ON x1 x3;


Specifically, I am wondering whether it is generally reasonable to set
up the variables as standard normal, enter the correlations among the
variables using a bunch of WITH statements, then analyze as a
regression model. Also, can you recommend a reference for using the monte carlo facility with relatively simple models, examples in the manual and your SEM article are quite advanced. Thanks.
 Linda K. Muthen posted on Sunday, December 14, 2008 - 4:37 pm
Regarding the analysis problem, please send your input, data, output, and license number to support@statmodel.com.

I would not recommend generating data according to the correlations. I would generate the data according to the regression model. Each example in the user's guide has a Monte Carlo counterpart. I would start with one of these. They are all very simple.
 Guy Cafri posted on Wednesday, December 17, 2008 - 5:26 pm
Thank you for the advice Linda. Are you saying that what I did was wrong or just not an advisable strategy because as the number of observed variables increases this approach would be too cumbersome? What I did seems to give the right answer, the average of the regression coefficients across replications is .23, which is the expected value of these coefficients if I do it manually with matrix algebra. Also, the power estimates are fairly close to what you would get using something like sas proc power.
 Linda K. Muthen posted on Wednesday, December 17, 2008 - 6:48 pm
No, I am not saying you are wrong. I was just suggesting a more simple approach.
 Guy Cafri posted on Tuesday, December 23, 2008 - 11:58 pm
Hi Linda,
I wanted to follow up on my original question regarding doing an EFA with 19 factors and 127 items with missing data. I was thinking about using multiple imputation as a way of getting around the convergence problem with ML estimation we talked about offline. In looking at one of the comments on the discussion board it sounded like type=imputation can't be used with efa. However, in another comment on the discussion board it sounded like type=imputation can be used with complex efa. The data I have are actually nested so using the complex option would be more appropriate. Can you please clarify what mplus can and can't do in terms of efa with imputed data sets? Thanks again for the help.
 Linda K. Muthen posted on Friday, December 26, 2008 - 8:23 pm
You cannot do TYPE=EFA with the IMPUTATION option. However, you can do EFA using a special feature added to the MODEL command in Version 5.1. See the Version 5.1 Language and Examples Addendems on the website with the user's guide.
 mari posted on Monday, March 21, 2011 - 1:38 pm
Hello Linda,
I have 20 multiply imputed data sets and want to run efa. When using type=imputation and type=efa, the model did not run in Mplus 6.1.

From your note about a special feature of EFA above, did you refer to page 529 in current UG? But the page does not say much about how to do EFA with imputed data sets. What would be a command for my case? I will appreciate any suggestions.
 Linda K. Muthen posted on Monday, March 21, 2011 - 5:58 pm
A post in 2008 would refer to the pages of the user's guide that was current them.

TYPE=EFA and TYPE=IMPUTATION cannot be used together. You can use TYPE=IMPUTATION with ESEM factors that are described in Examples 5.24 through 5.27 of the Version 6 user's guide and pages 575-578 of that guide.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: