Positive and negative factor loadings... PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
Message/Author
 Cathy Williams posted on Tuesday, July 17, 2012 - 1:39 pm
I am running a cfa and have found that two of the scales have both positive and negative loadings. I have examined the data set, checked the wording of the items, etc. Additionally, these scales have been used in prior research and so, from my perspective, should be valid. Do you have any thoughts as to why this might be occurring? Thank you!
 Linda K. Muthen posted on Tuesday, July 17, 2012 - 6:01 pm
Are you saying that two of the factor indicators load on more than one factor and that on one the factors the loadings are positive and on the other they are negative?
 Cathy Williams posted on Wednesday, July 18, 2012 - 5:45 am
In an initial attempt to identify factors in the data set I am using, I did a PCA using SPSS, and the 5 indicators for the factor (teacher/student relationship) were positive. When doing the CFA using Mplus, two of these factor indicators remain positive but three are now negative. This occurred for another factor, as well. Additionally, I did an EFA using Mplus and the results were quite different from the SPSS results. I guess I am just wondering if, being a new Mplus user, I have made an error that is causing these differing results. Thank you.
 Linda K. Muthen posted on Wednesday, July 18, 2012 - 6:11 am
It sounds like you are not reading your data correctly. Do a TYPE=BASIC with no MODEL command and see if your sample statistics look correct and your sample size is correct. You may have blanks in your data. This is not allowed with free format data.
 Cathy Williams posted on Wednesday, July 18, 2012 - 8:26 am
Problem solved! Thanks so much for your feedback!
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: