An indicator with three categories PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
Message/Author
 Subert Wu posted on Friday, November 24, 2000 - 9:31 pm
I have a CFA model including 18 indicators and 3 factors. The types of these observed variables are dichotomous except one with 3 categories. I use MPLUS 1.0 to estimate the model, but it can't work well.
Part of original programs are presented as follows:

VARIABLE:
NAMES ARE ID I1-I18;

USEVAR = I1-I18;

CATEGORICAL ARE I1-I18;

Then I view I18, which is a variable with three categories, as a continuous variable. It do work! And get the results as follows:

Chi-Square Test of Model Fit

Value 38.249
Degrees of Freedom 40
P-value .5492

Does the results are reliable ? If not, how can I solve the problem?
 Linda K. Muthen posted on Monday, November 27, 2000 - 3:08 pm
First of all, I highly recommend downloading Version 1.04 for all analyses.

I am not sure from the information that you give what happens when you treat the trichotomous variable as categorical. It may be that you don't have coverage in all bivariate cells. If the frequencies are very low in one category, you might consider collapsing categories. I would need more information about the variable to say anything meaningful.
 Anonymous posted on Monday, February 26, 2001 - 4:52 pm
I have run a CFA model with some dichotomous and categorical indicators (ESTIMATOR=WLSM was used). The model fit indexes CFI and TLI were about 0.80, indicating a very good fit. However, RMSEA and, particularly, WRMR, were large (see below). How should I interpret the mode fit? In addition, does Mplus provide 95% C.I. for RMSEA and the p-value for test of close fit (RMSEA<0.05) when categorical indicators are used?
Thank you very much for your help.


-------------------------------------------
CFI 0.981
TLI 0.979
RMSEA (Root Mean Square Error Of Approximation)
Estimate 0.081
WRMR (Weighted Root Mean Square Residual)
Value 1.246
 Anonymous posted on Monday, February 26, 2001 - 5:53 pm
Sorry, I made a typo error in the message I sent out this afternoon:
"... CFI and TLI were about 0.80,..." should be
"... CFI and TLI were about 0.98,..."
 Bengt O. Muthen posted on Monday, February 26, 2001 - 10:03 pm
The forthcoming Yu-Muthen paper suggests that TLI and CFI have rather low power to reject a model with binary outcomes, while WRMR works well, so it might well be that you should trust WRMR here and look for model modifications. Mplus does not offer CI's or p values for RMSEA with categorical outcomes.
 Anonymous posted on Thursday, March 08, 2001 - 4:58 pm
I have a CFA model with five categorical indicators (each has three levels) underlying a single factor. The model fit indexes are shown below (RMSEA<0.08 and SRMR<0.05, but RMR=0.698). Why WRMR is so large while the other two often used indexes are under their cutting points? Is the modet fit acceptable. Thank you very much for your help.

________________________________________________
RMSEA (Root Mean Square Error Of Approximation)
Estimate 0.051
SRMR (Standardized Root Mean Square Residual)
Value 0.022
WRMR (Weighted Root Mean Square Residual)
Value 0.698
 Linda K. Muthen posted on Thursday, March 08, 2001 - 9:14 pm
Recent studies indicate that a value less than .90 indicates good fit for WRMR. So according to WRMR your model fits well. WRMR is discussed on pages 361-361 of the Mplus User's Guide.
 Anonymous posted on Monday, February 09, 2004 - 7:56 pm
If I understand correctly, Muthén and Christoffersson (1981) specify the relationship between CFA for dichotomous categorical indicator item i and the 2-P IRT model as:

ICC slope = [Mplus scale factor] * lambda

ICC difficulty = threshold / lambda.

Does the same CFA 2-P IRT relationship hold in the case of categorical indicators with greater than k=2 categories ? If so, would you be kind of enough to provide a citation ?
 bmuthen posted on Tuesday, February 10, 2004 - 11:52 pm
See Mplus Web Note #4, section 2.3.
 Edward Barker posted on Thursday, March 08, 2007 - 11:44 am
Hello: I am trying to test if factor loadings are invariant across two age groups. My indicators are ordinal with three levels. I am wondering if I correctly specified the thresholds in the code below. Many thanks!

MODEL:

f1 BY ADHD1@1;
f1 BY ADHD2 (1);
f1 BY ADHD3 (2);
f1 BY ADHD4 (3);
f1 BY ADHD5 (4);
f1 BY ADHD6 (5);
f1 BY ADHD7 (6);
f1 BY ADHD8 (7);
f1 BY ADHD9 (8);

[F1@0];
{ADHD1-ADHD9@1};
{ADHD1-ADHD9@2};

MODEL 29-37:

f1 BY ADHD1@1;
f1 BY ADHD2 (1);
f1 BY ADHD3 (2);
f1 BY ADHD4 (3);
f1 BY ADHD5 (4);
f1 BY ADHD6 (5);
f1 BY ADHD7 (6);
f1 BY ADHD8 (7);
f1 BY ADHD9 (8);

[ADHD1$1 ADHD2$1 ADHD3$1 ADHD4$1
ADHD5$1 ADHD6$1 ADHD7$1 ADHD8$1
ADHD9$1 ];
[ADHD1$2 ADHD2$2 ADHD3$2 ADHD4$2
ADHD5$2 ADHD6$2 ADHD7$2 ADHD8$2
ADHD9$2 ];
 Linda K. Muthen posted on Thursday, March 08, 2007 - 12:34 pm
It looks like you did. Note that the default in Mplus is that factor loadings and thresholds are equal across groups. The equalities on your factor loadings are unnecessary. See in Chapter 13 the discussion of these defaults and other issues related to multiple group analysis including measurement invariance.
 Edward Barker posted on Thursday, March 08, 2007 - 12:53 pm
Thanks!
 Hsien-Yuan Hsu posted on Monday, May 05, 2008 - 9:39 pm
Dr. Muthen ,

In my study, "expectat" is an endogenous variable.

If I used
categorical = expectat;
CLUSTER IS cluster;
type =complex missing;

Mplus (v4.21) would do the listwise deletion.

If I used
!categorical = expectat;
CLUSTER IS cluster;
type =complex missing;

Mplus (v4.21) would use FIML without deletion.

Q: How could I use "categorical=" and "type = missing" features without deletion?

Thanks.

Mark
 Linda K. Muthen posted on Monday, May 05, 2008 - 10:19 pm
Please send your outputs and license number to support@statmodel.com. What you report does not sound correct.
 Heather Gilmartin posted on Tuesday, March 04, 2014 - 2:51 pm
I am running a CFA on a model with 4 latent variables - each with 8 measured items that are on a likert scale (1-5). The data has a non-normal distribution. I ran a WLSMV for the items are assumed categorical. The output for the "univariate proportions and counts for categorical variables" produced odd results.

Each item should have 5 categories. But, for items with 1-3 missing datapoints, it appears a 6th category was created. In the other direction, if choice "1 - never" on the Likert scale was not chosen for that item, only 4 categories were identified.

Is there a way to fix this? Or is there another possible explanation for why the category counts are off?
 Linda K. Muthen posted on Tuesday, March 04, 2014 - 4:05 pm
It sounds like you are reading the data incorrectly. Check that the variable names match the correct column in the data set. Check also to be sure there are no blanks in the data set which are not allowed with free format data. If you can't see the problem, send the output, data, and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: