Robust Chi-Square Difference Test PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 Luci M. posted on Friday, May 13, 2011 - 4:52 pm
Hi!

I would like to clarify which chi-square values to use for multiple group using MLR.

For the unconstrined model, do I use chi-square test of model fit? Or the chi-square test of model fit for the baseline model?

I have used the chi-square test of model fit from the unconstrained model and the the chi-square test of model fit from the constrained model.

There is a scaling corection factor for MLR under Loglikelihood for H0 - is this the one that is used?

For the unconstrained model (where paths are set to vary, thus not equal), I keep getting chi-square = 0, degree of freedom = o, p = .000. I am wondering why this is and does it make sense to compute the chi-square test with the scaling correction for MLR as per formula on the website or do I skip that given the 0 value for chi-square. Scaling correction is 1.000.

Thanks very much.
 Linda K. Muthen posted on Monday, May 16, 2011 - 11:10 am
If a model has no degrees of freedom, model fit cannot be assessed. The difference test is the chi-square value for the constrained model.
 Margarita Panayiotou posted on Tuesday, October 01, 2013 - 6:10 am
Dear Dr. Muthen,

I hope you are doing well. I have a quick question. I am running a simple mediation model, 1 DV, 1 IV, and 1 DV mediator.


Model:

VAR1 ON VAR2 VAR3;
VAR2 ON VAR3;

Model indirect:

VAR1 IND VAR3;

The direct effect of VAR3 on VAR1 is not significant, bu the indirect effect is. However, I get chi-square = 0, df = 0, p = .000.

I know I cannot say much about my model, but in cases like these can we report the mediation effects?

Thank you for your time!

Margarita
 Linda K. Muthen posted on Tuesday, October 01, 2013 - 9:46 am
Your model is just identified which is why you have degrees of freedom of zero and fit cannot be assessed. You can report the mediation effects.
 Margarita Panayiotou posted on Tuesday, October 01, 2013 - 10:13 am
Thank you for your prompt reply!

That actually helps a lot. Thanks.

Margarita
 Jean FRISOU posted on Wednesday, October 02, 2013 - 8:04 am
Hi,

I am testing the equality of the average slopes of growth model, with two groups (women and men) and estimator MLMV. The procedure is DIFFTEST.
In the output file the following message is indicated:
"THE MODEL ESTIMATION TERMINATED NORMALLY
THE CHI-SQUARE COMPUTATION COULD NOT BE COMPLETED
BECAUSE OF A SINGULAR MATRIX."
Only the test of differences is not displayed.
Are there alternative ways to DIFFTEST for this test?

Best regards,

Jean
 Linda K. Muthen posted on Wednesday, October 02, 2013 - 12:02 pm
Please send the output and your license number to support@statmodel.com.
 Margarita  posted on Tuesday, September 30, 2014 - 2:50 am
Dear Dr. Muthen,
I am working on a 2nd order CFA for measurement invariance but I receive an error in the most restrictive model and I am not sure why. The configural model works fine:

ESTIMATOR = WLSMV;
MODEL:
dom1 by q5 q6 q7 q20 q26 q30;
dom2 by q10 q15 q16 q17 q18;
dom3 by q9 q12 q13 q23 q24 q25;
qol by dom1 dom2 dom3;

[dom1-dom3@0];
[qol@0];
{q5-q30@1};

q24 with q25; ! Error covariance
q15 with q25;
q5 with q6; etc...

MODEL male:
dom1 by q6 q7 q20 q26 q30;
dom2 by q15 q16 q17 q18;
dom3 by q12 q13 q23 q24 q25;
qol by dom2 dom3;


[q5$1-q30$1];
[q5$2-q30$2];
[q5$3-q30$3];
[q5$4-q30$4];

Most restrictive:

MODEL:
dom1 by q5 q6 q7 q20 q26 q30;
dom2 by q10 q15 q16 q17 q18;
dom3 by q9 q12 q13 q23 q24 q25;
qol by dom1 dom2 dom3;

Error Message: THE MODEL ESTIMATION TERMINATED NORMALLY THE CHI-SQUARE COMPUTATION COULD NOT BE COMPLETED
BECAUSE OF A SINGULAR MATRIX.

THE STANDARD ERRORS OF THE MODEL PARAMETER ESTIMATES COULD NOT BE COMPUTED. THE MODEL MAY NOT BE IDENTIFIED. CHECK YOUR MODEL. PROBLEM INVOLVING PARAMETER 92. THE CONDITION NUMBER IS -0.527D-17.

Thank you so much
 Linda K. Muthen posted on Tuesday, September 30, 2014 - 6:09 am
Try running the first-order factors alone as a first step.
 Margarita  posted on Tuesday, September 30, 2014 - 7:15 am
Thank you for your prompt reply.

I already have and it worked fine. Results indicated non-invariance but I did not get any Error Messages.
 Bengt O. Muthen posted on Tuesday, September 30, 2014 - 8:32 am
Please send the output from the second-order model to Support with your license number.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: