Datafile problem in MPlus PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 Sukanlaya posted on Sunday, August 14, 2011 - 7:39 pm
Tried to run a simple regression model as below but it kept saying dat file has a problem. Read the disucssion and tried to solve problem per previous post (e.g. remove the variable names etc...) still not working. Please advice.
------------------------------

ITITLE: CAUSEE interaction
DATA: FILE IS W123MPlusv04.xls;
VARIABLE: NAMES ARE change renew different costlead sales experience industry profit bizoutcome;
ANALYSIS: TYPE = RANDOM;
ALGORITHM = INTEGRATION;
MODEL: change ON different;
change on costlead;
renew on different;
renew on costlead;
different on profit;
different on bizoutcome;
costlead on profit;
costlead on bizoutcome;
sales on different costlead;
experience on different costlead;
indusrty on different costlead;

OUTPUT: sampstat stdyx ;

*** ERROR
The number of observations is 0. Check your data and format statement.
Data file: \mplus\W123MPlusv04
*** ERROR
Invalid symbol in data file:
"ࡱ" at record #: 1, field #: 1
 Linda K. Muthen posted on Monday, August 15, 2011 - 6:13 am
It sounds like you have an invalid symbol in the data set. Perhaps the first record contains names of variables or some other characters. Open the data set and see if you can find the problem. If not send the data, output, and your license number to support@statmodel.com.
 Jahun Kim posted on Friday, May 10, 2013 - 10:52 am
I tried to run GMM but encountered error message saying dat file includes invalid symbol. I checked dat file but there is no symbol shown below.

=================================
TITLE: LCM Discrepancy

DATA:
FILE is
"C:\Documents and settings\administrator\desktop\DPP\Discrepancy LCM.dat";

FORMAT IS
(f8.0 11f8.2);

VARIABLE:
NAMES ARE study_id ETHFIN5 efhdep3p
amfqd2 bmfqd cmfqd dmfqd emfqd fmfqd
cpbicpco cpbicpre cpbicpmo;

*** ERROR
The number of observations is 0. Check your data and format statement.
Data file: C:\Documents and settings\administrator\desktop\DPP\Discrepancy LCM.dat
*** ERROR
(Err#: 64)
Invalid symbol at record #: 1
The record is shown below this message

The data record is too long to print. Refer to your data file.
The first 70 characters of the data record is printed below:
"癤? 11001 3.00 .00 3.92 16.00 999.00 14.00 999.00 9"
 Linda K. Muthen posted on Friday, May 10, 2013 - 1:04 pm
Open the file in the Mplus Editor. You will find the character as the first entry in the data set. Delete it and save it.
 Vanessa Madrazo  posted on Tuesday, January 21, 2014 - 1:03 pm
Hello,


I am unable to open the file with the version of MPlus that I have. Is it because I have the student version? (see below)

Mplus Version 7.11 Base Program Single-User License with pdf User's Guide (Students). Download contains both 32-bit and 64-bit programs for Microsoft Windows, Mac OS X, and Linux.
 Linda K. Muthen posted on Tuesday, January 21, 2014 - 1:31 pm
The student version is identical to the regular version. What do you mean by "unable to open the file". Which file?
 Margarita  posted on Monday, February 24, 2014 - 9:19 am
Dear Dr. Muthen,

I am trying to run a simple EFA and I get the same error, but the dataset seems fine.

DATA: FILE = '/Users/Desktop/pc.dat';
FORMAT = 16f1.0;

VARIABLE:

NAMES = pc1 pc2 pc3 pc4 pc5 pc6 pc7 pc8 pc9 pc10 pc11 pc12 pc13 pc14 pc15 pc16;

USEVARIABLES = pc1 - pc16;
CATEGORICAL = pc1 - pc16;


but i get the following message:


*** ERROR
The number of observations is 0. Check your data and format statement.
Data file: /Users/Desktop/pc.dat
*** ERROR
(Err#: 64)
Invalid symbol at record #: 1
The record is shown below this message
"Ԫ1114111111121312"

- I am using the SPSS20 and I working on a Mac. However, the rest of my datasets work fine
 Margarita  posted on Monday, February 24, 2014 - 10:24 am
Oh I corrected the problem!

I opened the dat. file using Mac TextEdit, and even though I could not see the "Ԫ" I deleted the empty space anyway, and the problem was fixed. Why is that? Was the symbol there, but could not read it in the TextEdit?
 Linda K. Muthen posted on Monday, February 24, 2014 - 10:30 am
Yes, the symbol was there but you could not see it. You did the correct thing. It seems to be related to a change in the last version of SPSS.
 Margarita  posted on Monday, February 24, 2014 - 10:46 am
I see.. I will keep that in mind.

Thank you so much for your reply!
 Sharon kwan posted on Wednesday, February 26, 2014 - 8:51 pm
Hello Prof,

I have the same problem as well. I have tried many times but still failed. I am trying to do EFA for 19 items. Below is the output.

INPUT INSTRUCTIONS

TITLE: efa bull
DATA: FILE IS C:\Users\kwass004 \Desktop\efa.bul.dat;
VARIABLE: NAMES ARE BUL1-BUL19;
ANALYSIS: TYPE = EFA 1 4;
OUTPUT: MODINDICES;

*** ERROR
The number of observations is 0. Check your data and format statement.
Data file: C:\Users\kwass004\Desktop\efa.bul.dat
*** ERROR
Invalid symbol in data file:
"" at record #: 1, field #: 1

sample file in dat. file (open with note pad)
1.00 1.00 1.00 1.00 1.00 2.00 1.00 2.00 1.00

I am trying to deleted the space to 1.00 1.00 1.00 1.00 1.00 as suggested in above messages but I still can't get the result. I am a PhD scholar. All my analysis depend to Mplus. Can you please advice me about this error? Thanks a lot!
 Linda K. Muthen posted on Thursday, February 27, 2014 - 6:03 am
Open the data file in the Mplus Windows Editor. Delete the invalid character and resave the data. You can only see this character in the Mplus Editor.
 Sharon kwan posted on Thursday, February 27, 2014 - 7:43 am
Thanks prof for your reply.
Do you mean that I open the dat.file through the mplus editor? I have tried to open the data file in mplus editor but couldn't. It only displayed the syntax file not the data file. Please advice. Thank you!
 Linda K. Muthen posted on Thursday, February 27, 2014 - 12:17 pm
You must be using the Mac version. Open the data file in MS Word. It will ask you about file conversion for the file. Choose the default text encoding (not Unicode (UTF-8) format). Then delete the invalid characters at the beginning of the first line.
 Sharon kwan posted on Thursday, February 27, 2014 - 6:29 pm
Prof, I got it. Thank you so much!!:-)
 christine meng posted on Sunday, March 02, 2014 - 1:09 pm
Hi Dr. Muthen,

I was running basic statistics for all my variables when I received the following error message. I opened the data file, but I didn't see any invalid symbol.

*** ERROR
(Err#: 64)
Invalid symbol at record #: 9
The record is shown below this message

The data record is too long to print. Refer to your data file.
The first 70 characters of the data record is printed below:
"440 1.00003 12000 1.77 .00 7.0 7.0 7.0 7.044 52.00 53.00"
 Linda K. Muthen posted on Sunday, March 02, 2014 - 5:06 pm
Please send the output, data set, and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: