Tech 7 PreviousNext
Mplus Discussion > Latent Variable Mixture Modeling >
 Mark Prince posted on Thursday, April 18, 2013 - 8:54 am

In a growth mixture model tech 7 provides means and covariances for the variables in the model separated by each latent class. Is there any way to request or even calculate by hand the standard errors or variances of the means for each latent class?

thank you,
 Bengt O. Muthen posted on Thursday, April 18, 2013 - 11:27 am
You would have to do this using MODEL CONSTRAINT to express the means in terms of model parameters that are labeled.
 Mark Prince posted on Thursday, April 18, 2013 - 1:08 pm
Thank you for the reply, but I am unsure how to use the model constraint command in the way you are suggesting. Here is my code:


CLASSES = c (4);

STARTS = 50 10;

i s q | x1@0 x2@1 x3@2 x4@3
x5@4 x6@5 x7@6 x8@7 x9@8
x10@9 x11@10 x12@11;


How would I use the model constraint command to get the standard errors for x1-x12 within each of the 4 classes? Can you give me an example of the code I would add?

Thank you.
 Bengt O. Muthen posted on Thursday, April 18, 2013 - 4:13 pm
Take a look at our short course teaching of Topic 3, particularly slide 98 showing how to compute estimated means at different time points. Drawing on that:

add in the MODEL command

[i-q] (p1-p3);

and using the example of the outcome mean at time point 3:

New (m3);
m3 = p1+p2*2+p3*9;

that is, multiply by the time scores and their squares. This gives you the mean estimate of m3 and its SE under New parameters.
 Mark Prince posted on Saturday, April 20, 2013 - 10:36 am
Hi - one last time on this question.

I appreciate the help thus far, and I was able to use your example to get the means and standard errors for each time point; however, I wasn't able to get the means and SEs for each time point within each class. The code you provided only gave me estimates for the overall model. I tried using the %c#1% statement but then I didn't know exactly what to call out, because if I put m1-m12 it was an unbalanced equation, and if I repeated the equations I used in the overall model, my model was over specified. Can you help me understand the final steps I need to take to get the separate estimates for means and SEs at each time point within each latent class?

Thank you for all the continued help.
 Bengt O. Muthen posted on Saturday, April 20, 2013 - 12:41 pm
You have to do the labeling in each class and compute this for each class. Don't do it in the Overall. So for class 1, 2, etc:

[i-q] (p11-p13);
[i-q] (p21-p23);


And in Model Constraint you define all your means, for each class.
 Mark Prince posted on Monday, April 22, 2013 - 7:53 am
Thank you for the helpful discussion so far. I have been able to estimate the means and SEs for each time point within each class using the syntax you provided; however, I am finding that the means calculated using the model constraint procedure are different from the TECH7 estimates - with some mean estimates extending beyond the possible range for the variables included. Ultimately, I would like the standard errors of the TECH7 estimates - so this might be a standard error weighted by the posterior probabilities. Can you shed some light on the discrepancies I am finding and/or lead me in the right direction to get the SEs I am looking for?

Thank you.
 Bengt O. Muthen posted on Monday, April 22, 2013 - 12:04 pm
TECH7 does not give model-estimated means. Instead, it is an attempt at creating "sample statistics" with mixtures. As an aide, this is often used in statistical articles, but is not a perfect sample statistic for means in mixture modeling since we don't observed the latent classes. But it is as close as you get; it is not perfect since you use model-estimated posterior probabilities.

If the Model constraint approach doesn't seem to give the right values, please send to support.
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message