Missing data imputation in 3-step? PreviousNext
Mplus Discussion > Latent Variable Mixture Modeling >
Message/Author
 James Lemoine posted on Wednesday, July 31, 2013 - 11:46 am
Thanks in advance for all the help this forum provides. I'm running a latent class analysis with a mixture analysis and using the 3-step procedure to test the latent classes' effects on an outcome variable (DU3STEP). There is some missing data in that outcome variable, so I was wondering if it would be possible to use imputation. I've got the analysis without missing data imputation working fine, but when I add:

DATA IMPUTATION:
IMPUTE = variablename;

to the syntax, I get an error message that there's an "Unknown variable(s) in the IMPUTE option: variablename". The variable name is spelled correctly and introduced earlier in the USEVARIABLES and AUXILIARY lines. This problem only seems to arise for variables I try to impute for which are also in AUXILIARY.

So my question is, is it possible to impute missing values for variables used in the AUXILIARY command? Or is this just a bad idea altogether since this variable is essentially the Y in my formula? What am I doing wrong? Please be gentle, I'm a neophyte!
 Linda K. Muthen posted on Wednesday, July 31, 2013 - 12:03 pm
Varibles on the AUXILIARY list are not used in the data imputation. They are saved with the imputed data. Example 11.5 goes over all of the related options. You might find that helpful.
 James Lemoine posted on Friday, August 02, 2013 - 7:11 am
Thank you for your reply. I have another question within the same general topic. I successfully ran an LCA and 3-step mixture analysis with a distal outcome. I then noticed some data on the outcome was marked as missing that I actually had, so I went back into the data file and added that data back in to the existing cases.

Now when I run the LCA/3-step with this single outcome, I get all 9999's for the results estimates/means/p-values of the distal outcome section. There are no new error messages other than the note that there were "problems with the distal outcome." The only difference between before (when it worked) and now (when it doesn't) is that there are fewer missing cases in the (binary) distal outcome. Do you have any information you could share on what might be causing this, and how I could run the analysis?
 Linda K. Muthen posted on Friday, August 02, 2013 - 8:33 am
Please send the two inputs, data sets, outputs, and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: