Suppress MS-DOS windows PreviousNext
Mplus Discussion > Latent Variable Mixture Modeling >
 Jitske Sijbrandij posted on Thursday, February 08, 2018 - 8:24 am
Hi all,

I'm running many growth mixture models with Mplus. Since it takes quite long to run all my models, I specified PROCESSORS = 4. When I'm running the models, 4 MS-DOS windows will pop up for each model. When I only use 1 processor, the MS-DOS windows do not pop up, but the code takes a lot longer to run.

Is there a way to suppress the MS-DOS windows?


 Bengt O. Muthen posted on Thursday, February 08, 2018 - 4:22 pm
I know of no way to suppress this - I don't see why you would want to.
 Jitske Sijbrandij posted on Friday, February 09, 2018 - 1:45 am
It takes more than a week to run my code, during which I work on the same computer. The windows pop up about every 10 seconds and the cursor also moves to the MS-DOS windows. Therefore, I have to move the cursor back to whatever I'm doing or wait until the MS-DOS windows dissapear again, every 10 seconds. This is not a very pleasant way to work.

Thank you for your reply. I hope perhaps someone else has an answer.
 Tihomir Asparouhov posted on Friday, February 09, 2018 - 8:21 am
command will work for you. The second number is the number of threads. You still get to use all four processors in one thread. In terms of speed it is only slightly slower than
 Jitske Sijbrandij posted on Monday, February 12, 2018 - 4:40 am
Thank you so much, Tihomir Asparouhov.
That indeed seems to do the trick.
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message