Mplus crash PreviousNext
Mplus Discussion > Growth Modeling of Longitudinal Data >
 Hee-Jin Jun posted on Tuesday, October 23, 2007 - 11:05 am
Dear Linda,

I am working on trajectory analysis.
Outcome variable is binary and we have 18 time point (age 0 to 17). Last three time points (age 15,16,17) we have some systematic missings (some kids haven't reached that age yet).
First I did it with the fixed time points (0 to 17), but it doesn't seem to fit well. So I tried to add quadratic term.
Unfortunately, it took quite a long time (few days) and then crashed (When I check the program, program was ended without output file.)
Next, I freed the time points except the first two. One day later, I also had the same results (program ended with no output file).

I am wondeing if this is a known bug or new one for you and how can I get the results. Because there is no output file, I don't even get any error message.

Thank you for your help.
 Linda K. Muthen posted on Tuesday, October 23, 2007 - 11:18 am
Please send your input, data, output, and license number to
 Hee-Jin Jun posted on Tuesday, October 23, 2007 - 12:20 pm
I have some clarification questions before I send the input file etc.

Is this the right way to add quadratic term?

i s q| wab0@0 wab1@1 wab2@2 wab3@3 wab4@4 wab5@5 wab6@6 wab7@7
wab8@8 wab9@9 wab10@10 wab11@11 wab12@12 wab13@13 wab14@14
wab15@15 wab16@16 wab17@17;

Is below the right way to freeing the time points?

i s| wab0@0 wab1@1 wab2 wab3 wab4 wab5 wab6 wab7 wab8 wab9
wab10 wab11 wab12 wab13 wab14 wab15 wab16 wab17;

If any answer is no, I'd rather do it again and send the results.


 Linda K. Muthen posted on Tuesday, October 23, 2007 - 12:53 pm
The answer is yes to both questions.
 Hee-Jin Jun posted on Tuesday, October 30, 2007 - 9:26 am
Dear Linda,

Running Mplus with a large datset with many time points has been challenging.
While I am running a program with 12 time points (N=around 6300), I found that the running time has increased dramatically. E.g. one iteration took about 7500 seconds, which is about 2 hours, for a day since yesterday. I am wondering this is some kind of sign that the program has some difficulties, so that it's better to close and try it again.
Thank you for your help.

86 -0.60855213D+05 0.0010999 0.0000000 EM 7472.53 79127.1
87 -0.60855211D+05 0.0014535 0.0000000 EM 7457.41 184.5

 Linda K. Muthen posted on Tuesday, October 30, 2007 - 1:01 pm
Please send your input, data, and license number to so I can see the particulars of your analysis.
 Sylvana Robbers posted on Wednesday, April 23, 2008 - 4:57 am
Dear Dr. Muthen,

I am running a growth curve model with clustered data and the grouping option:

i s q| extm3@0 extm4@1 extm6@3 extm7@4 extm8@5 extm9@6 extm10@7 extm11@8 extm12@9;

When I enter a dichotomous covariate (sex) like this:

i s q ON sex;

then I get no output. Not even an error message. After 5 seconds of 'running' I get my syntax-screen back.
Without the covariate things run just fine.

Do you have any idea why this happens and how I can solve it?

Thanks in advance.
 Linda K. Muthen posted on Wednesday, April 23, 2008 - 5:56 am
Please send your input, data, and license number to
 sed48 posted on Thursday, April 27, 2017 - 4:33 am
I'm having the exact same problem. Mplus does not automatically produce the output. When I search for it, it is there and reads "input terminated normally" and then the rest of the document is blank.

My code is:

Estimator = ML;


i s | mfq0@0 mfq6@1.2 mfq12@1.8
mfq36@4.3 mfq52@6 mfq86@9.5;

i WITH s;


SERIES = mfq0(0) mfq6(1.2) mfq12(1.8)
mfq36(4.3) mfq52(6) mfq86(9.5);

Is there an error in my code?
 Linda K. Muthen posted on Thursday, April 27, 2017 - 6:31 am
Please send the input, data, and your license number to
 sed48 posted on Friday, April 28, 2017 - 2:30 am
Actually I may have got it to run but I have a follow-up question. My data is normally distributed which is why I originally went with ML but I got it to run using MLR and TYPE=RANDOM instead of ML. Is it ok to use MLR anyway in this context to get it to run?
 Linda K. Muthen posted on Friday, April 28, 2017 - 6:25 am
I would want to understand why it did not run with ML. You may have different convergence criteria using RANDOM ML and MLR. You can check the outputs. It is never a good idea to leave an analysis without a clear understanding of the problem.
 sed48 posted on Friday, April 28, 2017 - 6:38 am
Yep that was my concern, I didn't know why it wouldn't run with ML. Ok, I will prepare the input and data to send to you and will try to write a bit about the steps I have/plan to take in case I have missed something important.

Thank you in advance for your help!
 Anne de Bruijn posted on Thursday, October 26, 2017 - 4:42 am
I have the same problem, I am trying to run a model with three continuous outcome variables using type = complex, but after about a minute Mplus stops running without giving any output. It does work when I lower the number of iterations, but then I get no convergence because the number of iterations exceeded. I am wondering why the model doesnt provide any output and whether there is something I can change to get Mplus providing output on my model?
 Bengt O. Muthen posted on Thursday, October 26, 2017 - 5:38 am
Please send your input and data to Support along with your license number and the version of the program you are using.
 Dennis Reidy posted on Tuesday, February 06, 2018 - 1:52 pm
I am trying to run a second order conditional latent growth curve using T-Scores. However, I've tried twice now and each time the program runs for a few hours before it seems to stop computing new iterations. It lists parameters and derivatives across the bottom of the DOS screen but DOS window doesn't close. It just seems to sit stagnant and I get no output.
 Bengt O. Muthen posted on Tuesday, February 06, 2018 - 3:13 pm
Please send to Support along with your license number.
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message