Non-Positive Definite Psi Matrix PreviousNext
Mplus Discussion > Growth Modeling of Longitudinal Data >
Message/Author
 Anonymous  posted on Wednesday, September 28, 2005 - 6:11 pm
I am analyzing short-term longitudinal data. I have 4 observation points sample size of 200 individuals. I have the model developed, but I continue to get an error message that the psi (latent variable) covariance matrix is not positive definite. After researching this issue, beyond consulting the Wothke article (I'm having trouble getting my library to order this article), what may I do to remedy this issue?

I believe that the data are salvagable so any tricks of the trade are well appreciated. Thanks in advance.
 Linda K. Muthen posted on Wednesday, September 28, 2005 - 6:22 pm
If you are using Version 3.13 it should point to which variable has the problem. You may have a negative residual variance or a correlation of one somewhere. You can see the negative residual variance in the results and you can ask for TECH4 to see if any variables have a correlation greater than one. Otherwise, you may have a dependency among two or more of your variables. If it is a small negative residual variance, you could fix it to zero. Otherwise, you would need to change your model. If you can't figure this out with this information, please send your input, data, output, and license number to support@statmodel.com.
 francesca scalas posted on Monday, July 16, 2007 - 2:36 am
Hi,
I am a beginner with Mplus and I am trying to understand growth models.

I have used this syntax:

MODEL:
ID SD | D1@0 D2@1 D3@2 D4@3;
IN SN | NEG1@0 NEG2@1 NEG3@2 NEG4@3;
IH SH | H1@0 H2@1 H3@2 H4@3;
IP SP | POS1@0 POS2@1 POS3@2 POS4@3;

but in the output there is a warning message:

WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE DEFINITE. THIS COULD INDICATE A NEGATIVE/RESIDUAL VARIANCE FOR A LATENT VARIABLE, A CORRELATION GREATER OR EQUAL TO ONE BETWEEN TWO LATENT VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE THAN TWO LATENT VARIABLES. CHECK THE TECH4 OUTPUT FOR MORE INFORMATION. PROBLEM INVOLVING VARIABLE IN.

In the tech4 section I have found that there are correlations higher than 1.
I don't understand exactly what does it mean and I don't know how to solve the problem. Could you help?

thank you very much,
francesca
 Linda K. Muthen posted on Monday, July 16, 2007 - 10:11 am
I think this will be solved if you include residual covariances among the outcomes at each time point, for example, d1 WITH neg1 etc.

Note that you should fit each process separately prior to putting them together in the same model.
 Liu Xiao posted on Friday, August 17, 2007 - 2:41 am
I am doing a latent growth modeling, and I meet the same problem. The syntax:

agg2 by zcpagg2
ztrext2 (1);
agg3 by zcpagg3
ztrext3 (1);
agg4 by zcpagg4
ztrext4 (1);
agg5 by zcpagg5
ztrext5 (1);
agg6 by zcpagg6
ztrext6 (1);
[zcpagg2 zcpagg3 zcpagg4 zcpagg5 zcpagg6] (2);
[ztrext2 ztrext3 ztrext4 ztrext5 ztrext6] (3);
i1 s1 | agg2@0 agg3@1 agg4@2 agg5@3 agg6@4;

zcpagg6 with zcpagg5;
zcpagg4 with zcpagg5;


WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE
DEFINITE. THIS COULD INDICATE A NEGATIVE VARIANCE/RESIDUAL VARIANCE FOR A
LATENT VARIABLE, A CORRELATION GREATER OR EQUAL TO ONE BETWEEN TWO LATENT VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE THAN TWO LATENT VARIABLES. CHECK THE TECH4 OUTPUT FOR MORE INFORMATION.PROBLEM INVOLVING VARIABLE AGG2.

I check the tech4, there are correlations higher than 1. In residual variance, there are agg2, agg3,agg4, agg6, lower than 0.

How can I fix this problem? Can I use the MODEL CONSTRAINT to constraint the residual variance larger than 0 and smaller than 1?

Thanks for your help.
 Linda K. Muthen posted on Friday, August 17, 2007 - 8:48 am
Having only two indicators for your factors can be problematic as the factor at each time point is not identified without borrowing information from other parts of the model. Try running the model without measurement invariance and without the growth model to see if the problem occurs with that model. If so, the model is probably not correct for the data. If it occurs only after imposing measurement invariance, it may be that the factors are not invariant across time.
 Virginia Vitiello posted on Friday, August 31, 2007 - 1:33 pm
Hello, I have a quick question.

I'm using a latent growth model to model math achievement across 3 time points. I've gotten the same message that others have written about (PSI matrix is not positive-definite). The problem involves the variable "linear" (ie, the latent variable representing linear growth).

There are no negative residual variances, although the residual variance for "linear" is 0.000. I've checked my variables for collinearity and do not believe that to be a factor. I've also made sure that the variables have similar variances. One of my math variables has very high kurtosis (39). I've tried transformations (square root, natural log, and inverse; then I reflected the variable and tried all 3 again)--the transformations only make the kurtosis worse.

Does anyone have any suggestions for how to fix this problem? Could it be due to the kurtosis, and if so, how does this affect the accuracy of the estimates that Mplus calculates?
 Bengt O. Muthen posted on Friday, August 31, 2007 - 6:56 pm
You say the residual variance for the linear slope is 0. That could be a cause for the message, for example if the slope is regressed on the intercept. Or the slope and the intercept are correlated 1.0 - which you can see in the TECH4 output. To avoid this you may want to center at a different time point.
 Virginia Vitiello posted on Monday, September 03, 2007 - 7:55 am
The slope and intercept were actually not correlated very highly. I did try centering at a different time point, but it didn't help. I finally fixed the "linear" residual variance to .001 (based on other posts & responses, it seems that this is acceptable), and stopped getting the error message.

If this is not a good solution, I'd appreciate hearing about it, although it seems that others have done similar things.

Thanks for the help.
 Antonio A. Morgan-Lopez posted on Monday, September 03, 2007 - 8:25 am
Hi Virginia,

What may also be happening in your data is something that seems to occur more in achievement data than any other type of data: insufficient changes in rank-order for modeling *variability* in growth (i.e., *very* high correlations between repeated measures). I ran into a similar problem as yours in working with some early reading achievement data (i.e., pre-kindergarten through 4th grade) - and (according to some developmental psychologist friends of mine) for some (but not all) types of achievement outcomes this phenomenon seems consistent with literature that suggests that, after a certain point kids tend to maintain their rank ordering in achievement.

I'd still wait to see what Bengt suggests you do about it - but you may want to peek at the sample correlations (and see if they are really high) to help diagnose where this is coming from......
 Linda K. Muthen posted on Monday, September 03, 2007 - 10:14 am
It's hard to say more without further information. Please send your input, data, output, and license number to support@statmodel.com.
 pm posted on Monday, November 12, 2007 - 12:52 pm
Hello,

We are looking at academic achievement data using the same measure at three time points. We have four outcome variables: math, vocabulary, listening comprehension, and alphabet knowledge.

We first ran the model for math, and it worked just fine. We then tried to run the models for the other three outcomes and we received the following message:

WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE
DEFINITE......

Upon reviewing the output, we notice we have a correlation between baseline and linear that is greater than 1. We have tried centering the variables at each time point and we've checked for collinearity. However, we still get the same warning message. We do not have enough df to do all of the with statements and therefore, that is not an option for us. We are not sure why the intercept and growth terms are so highly correlated and what we can do about it at this point.

Thank you for your help.
 Bengt O. Muthen posted on Monday, November 12, 2007 - 1:06 pm
Is the slope variance significant?
 pm posted on Thursday, November 15, 2007 - 1:00 pm
Hello,

The slope variance is not significant (-.105).

Thank you.
 Bengt O. Muthen posted on Thursday, November 15, 2007 - 1:23 pm
Then I would fix the slope variance at zero, and then there would be no intercept-slope covariance and no Psi problem.
 Michael Spaeth posted on Wednesday, November 28, 2007 - 11:13 am
Hello,

I'm doing a unconditional LGGM with alcohol use data. When I assumed 3 classes I also received above mentioned warning. Looking at tech4 revealed that I have a negative variance in my Intercept.
Some colleagues mentioned that it helps to fix variances of the slope and/or intercept to zero to avoid the warning. But the variances of my intercept and slope are significant. Is fixing the variance of the slope or intercept to zero really the right way to handle that problem?
Additional information:
1)My Data is skewed and has a preponderance of zeros and i haven't done two part yet,is this problem related to psi-warning?, (I'm doing LGMM with MLR instead, to get a clue about LGMM, which is a new topic for me).
2)I have some outliers at time1 (which is the intercept). Would deleting them be helpful?
3) are there any model restrictions (in LGGM default by mplus 4.21) which may foster the psi-problem? Can I free/fix a parameter (beside above mentioned variances) to solve the problem?
 Linda K. Muthen posted on Wednesday, November 28, 2007 - 2:41 pm
If you have a significant negative residual variance, the model is not appropriate for the data. Outliers and a preponderance of zeros should be considered. Please send your input, data, output, and license number to support@statmodel.com for further comments.
 Jungeun Lee posted on Sunday, December 16, 2007 - 5:51 pm
Hi!

Related to the post 'pm posted on Monday, November 12, 2007 - 12:52 pm' and 'Bengt O. Muthen posted on Monday, November 12, 2007 - 1:06 pm', can we trust variance estimates got from the model that we get some warnings like 'non-positive PSI', 'parameters were fixed to avoid singularity of the information matrix'?
 Linda K. Muthen posted on Monday, December 17, 2007 - 7:56 am
This depends on the situation. Please send the input, data, output, and your license number to support@statmodel.com.
 Jungeun Lee posted on Monday, May 26, 2008 - 4:08 pm
Hi!

I am working on a growth mixture model. When I have more than 2 classes without constraining within-class variances, I meet the same problem (PSI is not positive definit). Whenever I have this problem, I am pretty puzzled about what I can do about it. Could you give us a general guidance in what we can do about it to fix this problem? OR, solutions to this problem depends on the situation?
 Linda K. Muthen posted on Tuesday, May 27, 2008 - 8:11 am
These problems depend on the situation. You can send your input, data, output, and license number to support@statmodel.com is you want further information.
 Daniel Seddig posted on Monday, December 08, 2008 - 6:56 am
hi,

i am working on a growth curve model with an intercept and a slope factor. outcome variable is the summarized annual rate in self-reported delinquency for 15 offenses. the rate is transformed to its natural logarithm. besides that i included a range of TVCs (modelled as markov-chains) and three TICs. i have five time-points to analyze. the slope factor loadings are fixed to 0 and 1 for time point 1 ad 2 resp. the rest is freely estimated. all constructs (except the TICs) are treated as latent variables.

here comes the problem:

when estimating the model under listwise deletion conditions everything is fine. using the option of full information estimation leads to a correlation greater 1 between intercept and slope. i am wondering why? and what can be done? fixing the variance at a certain value? fixing the growth factor means at zero (loss of information)?

thanks for your time. daniel
 Linda K. Muthen posted on Monday, December 08, 2008 - 8:57 am
The data are quite different when you use listwise deletion versus TYPE=MISSING; which suggests the listwise deletion sample is selective.

To better understand why you get growth factors correlating greater than one, I would first fit the growth model without covariates. Then I would add time-invariant covariates. After that I would add time-varying covariates.
 Bettina Doering posted on Monday, August 31, 2009 - 7:07 am
Dear Prof Muthen

me again. Is there any possibility to change something in the model or any way out this problem?

THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE DEFINITE.

That is the modell:
W1_TA by w1_taet2 w1_taet4 w1_taet5 w1_taet6;
W2_TA by w2_taet2 w2_taet4 w2_taet5 w2_taet6;
W3_TA by w3_taet2 w3_taet4 w3_taet5 w3_taet6;
W1_OP by w1_opf2 w1_opf3 w1_opf4 w1_opf5;
W2_OP by w2_opf2 w2_opf3 w2_opf4 w2_opf5;
W3_OP by w3_opf2 w3_opf3 w3_opf4 w3_opf5;

W2_TA on w1_OP w1_TA;
w2_OP on w1_OP w1_TA;
w3_TA on w2_OP w2_TA;
w3_OP on w2_OP w2_TA;

w1_OP with w1_TA;
w2_OP with w2_TA;
w3_OP with w3_TA;

Thank you,

Bettina
 Linda K. Muthen posted on Monday, August 31, 2009 - 7:47 am
Please send your output and license number to support@statmodel.com.
 Wayne deRuiter posted on Friday, July 23, 2010 - 1:27 pm
Hello,

I am doing a parallel process model using the following syntax;

i1 s1 q1|pa4@0 pa6@1 pa8@2 pa0@3 pa2@4 paA@5 paB@6;
i2 s2|sk4@0 sk6@1 sk8@2 sk0@3 sk2@4 skA@5 skB@6;
s1 ON i2;
s2 ON i1;
q1 ON i2;
s1 WITH S2;

After running this syntax I get the following message:

WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE DEFINITE. THIS COULD INDICATE A NEGATIVE/RESIDUAL VARIANCE FOR A LATENT VARIABLE, A CORRELATION GREATER OR EQUAL TO ONE BETWEEN TWO LATENT VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE THAN TWO LATENT VARIABLES. CHECK THE TECH4 OUTPUT FOR MORE INFORMATION. PROBLEM INVOLVING VARIABLE S2.

After checking TECH4, I see that in the estimated covariance matrix I have negative values and values greater than 1. How can I solve this problem?

In the the estimated correlation matrix, I have negative values. This should not be a problem, should it?

Thanks
Wayne
 Linda K. Muthen posted on Friday, July 23, 2010 - 2:24 pm
Please send your output and license number to support@statmodel.com.
 Carolin posted on Monday, August 01, 2011 - 2:46 am
Dear Mrs and Mr Muthén,

I have fixed i@0 in the linear three class model (GMM) because of a non-positive definite psi matrix (variance of i was small and not significant).

My question: do I have to fix i@0 in the quadratic model or the 4 class model too for better comparability or parsimony?

Thanks a lot
 Linda K. Muthen posted on Monday, August 01, 2011 - 10:49 am
I would only fix it in the quadratic model if it is estimated as a small negative value.
 Alan Gow posted on Wednesday, August 24, 2011 - 5:01 am
I'm running a growth curve model with 3 latent factors (each defined by 4 measures). The warning message
WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE
DEFINITE. THIS COULD INDICATE A NEGATIVE VARIANCE/RESIDUAL VARIANCE FOR A
LATENT VARIABLE, A CORRELATION GREATER OR EQUAL TO ONE BETWEEN TWO LATENT
VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE THAN TWO LATENT VARIABLES.
CHECK THE TECH4 OUTPUT FOR MORE INFORMATION.
PROBLEM INVOLVING VARIABLE I.

appears. Checking TECH4 shows a correlation greater than 1 with the first factor and a covariate. How can I remedy this?
 Linda K. Muthen posted on Wednesday, August 24, 2011 - 1:00 pm
You may need a direct effect from the covariate to a factor indicator. Check the modification indices.
 Till posted on Tuesday, September 13, 2011 - 6:09 am
Dear Mrs. and Mr. Muthén,
I'm conducting a latent growth curve analysis with the factors F1 F2 F3 as latent exogenous variables. I'am interested in the parameter loadings between these factors and the slope.
Slope and intercept are assessed at nine time points.
In one sample, MPlus warns me that the latent variable covariance matrix is not positive definit which seems to be due to a negative residualvariance and a negative variance of the slope. Is there a way to solve that problem, for example by fixing the residualvariance to 0.01 or would that mean to suppress the variance of the slope which I'am mainly interested in?
Could I, as an Alternative, just report the unstandardized values of the parameters?
Please find my Input data below:

variable: names= g1 e1 n1 g2 e2 n2 g3 e3 n3 l01 l02 l03 l04 l05 l06 l07 l08 l09;
usevariable=all;
missing=all(99);


model: i s | l01@0 l02 l03 l04 l05@-1 l06 l07 l08 l09;
F1 by n1 n2 n3;
F2 by e1 e2 e3;
F3 by g1 g2 g3;
i s on F1 F2 F3;

Analysis:
Estimator=MLR;

output: samp standardized tech4;

Thank you very much in advance
Kind regards
Till
 EFried posted on Saturday, January 21, 2012 - 12:27 pm
We are using a simple growth model at the moment before including the other covariates.

i s | y0@0 y1@1 y2@2 y3@3 y4@4;

We get the PSI warning that people have mentioned in the thread.
TECH4 shows a value of 1.004 between S and I in the correlation matrix, I guess that's the reason.

So I included
y0 y1 y2 y3 PWITH y1 y2 y3 y4;
as seen in one of your videos. This changes the correlation to -0.028, the PSI warning disappears, and the MI also get smaller (highest one from 240 to 190, but still high).

However, since the MI indices are very high and the fit is bad, I freed the last 3 timescores (y0@0 y1@1 y2*2 y3*3 y4*4;). The fit indices get wonderful and the MI indices much better, but the correlation between I and S goes up again to 3.9 again and the PSI warning appears.

The same happens in models with several classes as soon as I move from a LCGA model (i-s@0;) to a GMM model (!i-s@0): good fit, but correlation between I and S >1.

(Negative residual variances seem not to be a problem.)

Thank you for suggestions
Torvon
 EFried posted on Saturday, January 21, 2012 - 1:03 pm
(Update: in some class solutions I do actually have negative residual variances in the biggest class, usually on I. In the so far best 2 class solution the negative residual variance of I = -.6, too big to just fix it to zero )
 Linda K. Muthen posted on Sunday, January 22, 2012 - 2:06 pm
I would run the model with one class as a first step. Try centering the time scores in the middle.
 EFried posted on Sunday, January 22, 2012 - 11:11 pm
Linda, I ran the models with only one class as first step and encounter the problem, as described above.

I also tried now to center the time scores in the middle and still get the warning. No negative residual variances, but a correlation higher than 1 between Intercept and Slope in class2.

What else can I do to fix this? Thank you!
Torvon
 Linda K. Muthen posted on Monday, January 23, 2012 - 1:32 pm
Please send the one class output and your license number to support@statmodel.com.
 Jean-Samuel Cloutier posted on Tuesday, February 21, 2012 - 6:59 am
Hi
I have run this model

F11 by x11 x21 x31
F21 by F11 y1 z1

F12 by x12 x22 x32
F22 by F2 y2 z2

[...]

F1n by x1n x2n x3n
F2n by F1n yn zn

F3 by f21 f22 ... f2n
______________________________________
All observed variables x y z are categorical. We have 7 years of measure for all observed dimentions.

If I run every year independently, every single year model return a good fit.

When I add the latent variable F3 to capture the persistence of simultaneous superior F1, y and x, some correlation problems emerge.

When I use 3 years, the model return negative residual variance around -0,5 -0,75.

When I use all years, tetrachoric correlation between different year observation can,t be computed (acce1 and acce2 for example).

The problem pertain to high correlation between latent variables. But since these high correlation relate to the dependence between each parallel year observation, how should i fix this.
 Linda K. Muthen posted on Tuesday, February 21, 2012 - 1:47 pm
Too much of the correlations may be forced to go through the factors. Ask for modification indices and see if there are correlations needed among the observed variables.
 rgrove posted on Thursday, March 15, 2012 - 3:22 am
Hi,

I am receiving the same non-positive definite psi matrix error when running a CFA.

My model is COG BY cog_emp* EYES KDEF;
EMOT BY comt_emp* AQ_soc;

COG@1;
EMOT@1;
EMOT WITH COG;

I have no negative residuals. Is it that the correlation between my variables is -1.05? How do I account for this in my model?


Thanks for your help
 Linda K. Muthen posted on Thursday, March 15, 2012 - 6:52 am
Yes, a correlation greater than one will generate the message. This makes your model inadmissible. You must change your model.
 Jeremy Dawson posted on Wednesday, May 02, 2012 - 4:22 am
Hi,

I'm trying to run a straightforward growth curve model of a single observed variable over 5 time points, and I am getting the non-positive definite PSI matrix error. The slope term is causing a problem: according to the TECH4 output the correlations of S with S, and of S with I, are both 999. I had previously tried running it with a larger data set, when the correlation of S with I was estimated as above 3, and most of the other parameters seemed to be estimated normally.

There is nothing strange about the data as far as I can tell - all five variables are roughly normally distributed, with correlations between the time points ranging from 0.43 to 0.59.

My model syntax is as follows (which works fine for different variables):

i s | errs07@0 errs08@1 errs09@2 errs10@3 errs11@4;

Many thanks in advance for any suggestions you might have!
Jeremy
 Linda K. Muthen posted on Wednesday, May 02, 2012 - 9:42 am
Try centering the time scores, for example,

i s | errs07@-2 errs08@-1 errs09@0 errs10@1 errs11@2;
 Michael posted on Tuesday, May 08, 2012 - 6:08 am
Dear Dr.s Muthen,

I´m running an growth curve model with 4 time points. When I use only an linear latent slope, the model is performing well. when I introduce an quadratic slope I get the warnings
WARNING: THE RESIDUAL COVARIANCE MATRIX (THETA) IS NOT POSITIVE DEFINITE.

and

WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE DEFINITE.

Indeed, I checked, the model estimates two negativ variances

here´s my input

i1 s1 q1| y11@0 y21@1 y31@2 y41@3 ;
i2 s2 q2| y12@0 y22@1 y32@2 y42@3 ;

Y11 Y21 Y31 Y41 pwith Y12 Y22 Y32 Y42 ;

s2 on i1;
s1 on i2;
q2 on s1;
q1 on s2;

i1 with s1;
i2 with s2;
q1 with i1;
q1 with s1;
q2 with i2;
q2 with s2;

I do not understand why this warnings occur. the numer of free parameters is 36, as much as my empirical parameters. Is it an identification problem?

Many thanks in advance

Michael
 Jeremy Dawson posted on Tuesday, May 08, 2012 - 8:05 am
Thanks for the suggestion (centering the time scores) - unfortunately this doesn't work, and I get the same error message. Do you have any other ideas?

Many thanks,
Jeremy
 Roos Hutteman posted on Tuesday, May 08, 2012 - 9:40 am
Dear Drs. Muthén,

I am trying to estimate a multiple indicator linear growth model for two parallel processes for continuous outcomes and I am getting the warning that the latent variable covariance matrix (PSI) is not positive definite.

When inspecting the model results and TECH4 output, it turns out that one of the slopes has a negative variance and a correlation of 999 with all other latent variables. I have tried to center the time scores, but this doesn’t solve the problem. When I fix the variance of the slope to zero I do not get the warning anymore, but the correlation between the slope and all other latent variables remains to be 999 and more importantly, it does not allow me to investigate the correlated change. Is it possible to solve this problem without fixing the variance of the slope to be zero?

Thank you very much for your help and suggestions in advance!

Best,

Roos Hutteman
 Linda K. Muthen posted on Wednesday, May 09, 2012 - 9:52 am
Michael:

The message is because of the negative residual variances. You can try holding them equal across time.
 Linda K. Muthen posted on Wednesday, May 09, 2012 - 9:53 am
Jeremy:

It sounds like the data and model are not compatible.
 Linda K. Muthen posted on Wednesday, May 09, 2012 - 9:54 am
Roos:

If the negative residual variance is small and not significant, you can fix it to zero.
 Sarah Phillips posted on Monday, May 21, 2012 - 9:35 am
Hello,

I am doing a multi-group comparison of a pretty complicated SEM model. When I run the analysis, the model converged for two of my groups but not the third. For this group, I get a not positive definite psi matrix.

The problem is with the residual variance of my latent outcome. The size of the residual variance is -.015 and it is highly insignificant p=.623.

For the other groups, the residual variance is very small (.008 and .007) and also insignificant (.781 and .819).

I am wondering if it would, therefore, be justifiable to fix the residual variance of this latent variable to zero?

Thanks,

Sarah
 Sarah Phillips posted on Monday, May 21, 2012 - 10:04 am
Hello,

Sorry for the previous message, I was looking at the wrong version of my model. This is a cross-sectional complex model where I am doing a multi-group comparison. The model is pretty complicated. When I run it, I get a not positive definite psi matrix for all my groups.

The problem is with the residual variance of my latent outcome. The size of the residual variance is -.002, -.004, and -.024 depending on the groups and is highly insignificant p>.5

Given this, I am wondering if it would be justifiable to fix the residual variance of this latent variable to zero?

Thanks,

Sarah
 Linda K. Muthen posted on Monday, May 21, 2012 - 11:26 am
Please send the output and your license number to support@statmodel.com.
 Danyel A.Vargas posted on Monday, August 19, 2013 - 8:15 pm
Hello Dr. Muthén,

I am trying to run this GMM but am getting an error:
WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IN CLASS 2 IS NOT POSITIVE DEFINITE. THIS COULD INDICATE A NEGATIVE VARIANCE/RESIDUAL VARIANCE FOR A LATENT...

Is it because I'm getting a negative variance?

ESTIMATED COVARIANCE MATRIX FOR THE LATENT VARIABLES
ICEPT LINEAR
________ ________
ICEPT 0.082
LINEAR 0.021 -0.007

How can I fix this? I read the other posts but I wasn't sure and don't want to do it incorrectly.

Thank you very much,

Danyel
 Bengt O. Muthen posted on Tuesday, August 20, 2013 - 7:41 am
Yes, a negative variance gives this message. This implies that the latent classes explain all variation in the linear growth factor and there is no further within-class variation. You can fix this variance at zero, or you can use fewer classes.
 Danyel A.Vargas posted on Tuesday, August 20, 2013 - 8:50 am
Thank you for replying. I fixed it to zero and still received the same message. It said to look at class 2 matrices, but don't see what it's referring to.

ESTIMATED MEANS FOR THE LATENT VARIABLES
ICEPT LINEAR
________ ________
1 1.502 -0.083


S.E. FOR ESTIMATED MEANS FOR THE LATENT VARIABLES
ICEPT LINEAR
________ ________
1 0.100 0.016


ESTIMATED COVARIANCE MATRIX FOR THE LATENT VARIABLES
ICEPT LINEAR
________ ________
ICEPT 0.258
LINEAR -0.038 0.000


S.E. FOR ESTIMATED COVARIANCE MATRIX FOR THE LATENT VARIABLES
ICEPT LINEAR
________ ________
ICEPT 0.018
LINEAR 0.002 0.000


ESTIMATED CORRELATION MATRIX FOR THE LATENT VARIABLES
ICEPT LINEAR
________ ________
ICEPT 1.000
LINEAR 999.000 999.000


S.E. FOR ESTIMATED CORRELATION MATRIX FOR THE LATENT VARIABLES
ICEPT LINEAR
________ ________
ICEPT 0.000
LINEAR 999.000 0.000
 Linda K. Muthen posted on Tuesday, August 20, 2013 - 12:29 pm
Please send the output and your license number to support@statmodel.com.
 Danyel A.Vargas posted on Friday, August 30, 2013 - 11:55 am
Hello,

I have fixed this variance to zero, but after reading some more on your website it seems that I should not fix this variance to zero if it significant correct? The slope variance of -.007 is significant. See below for reference.


Linda K. Muthen posted on Wednesday, November 28, 2007 - 2:41 pm
If you have a significant negative residual variance, the model is not appropriate for the data. Outliers and a preponderance of zeros should be considered. Please send your input, data, output, and license number to support@statmodel.com for further comments.
 Bengt O. Muthen posted on Friday, August 30, 2013 - 2:48 pm
Linda's answer applies.
 Danyel A.Vargas posted on Friday, August 30, 2013 - 4:23 pm
Dr. Muthén,

Thank you for replying. I appreciate it.

Danyel
 Danyel A.Vargas posted on Sunday, September 15, 2013 - 2:48 pm
Dr. Muthén,

I'm estimating a dyadic growth model and am getting a warning about one of the latent variables, but cannot see why this warning is coming up. Can you please help?

THE MODEL ESTIMATION TERMINATED NORMALLY

WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE
DEFINITE. THIS COULD INDICATE A NEGATIVE VARIANCE/RESIDUAL VARIANCE FOR A
LATENT VARIABLE, A CORRELATION GREATER OR EQUAL TO ONE BETWEEN TWO LATENT
VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE THAN TWO LATENT VARIABLES.
CHECK THE TECH4 OUTPUT FOR MORE INFORMATION.
PROBLEM INVOLVING VARIABLE SW.
Thanks,

Danyel
 Linda K. Muthen posted on Sunday, September 15, 2013 - 4:12 pm
Please send the output and your license number to support@statmodel.com.
 Jonathan Larson posted on Thursday, April 03, 2014 - 7:30 am
One of our analyses generated the message below. The problem variable (S) has a positive variance that is not significantly different from zero. We have at least one correlation greater than 1. Is it permissible to fix the variance of S to zero, and could it resolve the problem of having correlations greater than 1?

Thank you!

WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IN CLASS 1
IS NOT POSITIVE DEFINITE. THIS COULD INDICATE A NEGATIVE VARIANCE/
RESIDUAL VARIANCE FOR A LATENT VARIABLE, A CORRELATION GREATER OR EQUAL
TO ONE BETWEEN TWO LATENT VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE
THAN TWO LATENT VARIABLES. CHECK THE TECH4 OUTPUT FOR MORE INFORMATION.
PROBLEM INVOLVING VARIABLE S.
 Bengt O. Muthen posted on Thursday, April 03, 2014 - 8:02 am
If the correlation >1 is between s and i, then yes that would be a possible remedy.
 Jonathan Larson posted on Thursday, April 03, 2014 - 8:53 am
The correlation between I and S was greater than 1. Strangely, the correlations between Q and every other latent variable were also greater than 1, but no warning message was generated for Q until after the variance of S was fixed to 0.

In the event that this error message is generated for multiple parameters at once, should they all be constrained at once? Or is it possible that constraining one will resolve the problems with the others?

Thanks for your help!
 Bengt O. Muthen posted on Thursday, April 03, 2014 - 3:49 pm
The latter.
 Jonathan Larson posted on Friday, April 04, 2014 - 8:08 am
Thank you!
 Marijka Batterham posted on Thursday, September 11, 2014 - 8:56 pm
I am running a GMM with a quadratic and cubic term, both significant, VARIABLE: NAMES ARE b1-b5;
Missing are all (-999);
CLASSES = c (3);
ANALYSIS: TYPE = MIXTURE;
STARTS = 400 20;
MODEL:
%OVERALL%
i s q u| b1@0 b2@1 bi3@2 b4@3 b5@4;
OUTPUT: TECH1 TECH4;

I receive this message
WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IN CLASS 1
IS NOT POSITIVE DEFINITE. THIS COULD INDICATE A NEGATIVE VARIANCE/
RESIDUAL VARIANCE FOR A LATENT VARIABLE, A CORRELATION GREATER OR EQUAL
TO ONE BETWEEN TWO LATENT VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE
THAN TWO LATENT VARIABLES. CHECK THE TECH4 OUTPUT FOR MORE INFORMATION.
PROBLEM INVOLVING VARIABLE U.
I looked at tech 4, not sure what the problem is.

If I drop the cubic term and leave the quadratic (some of the curves look quadratic) I get

WARNING: THE RESIDUAL COVARIANCE MATRIX (THETA) IN CLASS 1 IS NOT
POSITIVE DEFINITE...CHECK THE RESULTS SECTION FOR MORE INFORMATION.
PROBLEM INVOLVING VARIABLE B5.
for all the classes

There is substantial missing data at timepoint B5. B5 has a negative residual variance. I am not sure how to improve this model? thanks
 Linda K. Muthen posted on Friday, September 12, 2014 - 6:26 am
The message is caused by the negative residual variance which makes the results inadmissible. If it is small and not significant, you can try fixing it to zero. You can also try holding the residual variances equal across time.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: