Parallel growth curve process: error ... PreviousNext
Mplus Discussion > Growth Modeling of Longitudinal Data >
 radanielina-hita marie louise posted on Monday, February 06, 2012 - 1:07 pm
I ran parallel growth curve process for my dissertation and I got good fit indices. DATA:
FILE IS "F:\files in the floppy disk\ANALYSES DISSERTATION backup
\DATA WITH LATE ADDITION\growth curve.dat";


NAMES ARE y22 y13 y23 y21 y11 y12;

MODEL: i1 s1| y11@0 y12@1y13@2;
i2 s2| y21@0 y22@1y23@2;

s1 ON i2;
s2 ON i1;


I got the means for the intercepts, slopes, variances around the intercepts, and intercept1 on slope 2 and intercept 2 on slope 1. However, Mplus also had an error message "THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE DEFINITE. This could indicate a negative variance/residual variance for a latent variable"
My first construct has a linear decrease across time so the residual variance is indeed negative. Do I need to worry about this error message or may I present this output?

 Linda K. Muthen posted on Monday, February 06, 2012 - 1:52 pm
No variance or residual variance estimate should be negative. This makes the model inadmissible. If your outcome decreases over time, this is seen in the negative mean of the slope growth factor not in a negative residual variance.
 radanielina-hita marie louise posted on Monday, February 06, 2012 - 3:14 pm

When I ran the latent growth curves separately, they work fine. I do not get a negative residual variance.
Is it something in the codes of my parallel growth curve process?

Thanks in anticipation
 Linda K. Muthen posted on Monday, February 06, 2012 - 4:03 pm
Perhaps you need residual covariances at each time point across the two processes.
 radanielina-hita marie louise posted on Monday, February 06, 2012 - 4:29 pm
Yes. That is what I just did and it is now working.

Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message