MI Datasets Generated Outside of Mplus PreviousNext
Mplus Discussion > Missing Data Modeling >
 Rob White posted on Monday, September 24, 2007 - 10:46 am

I generated X multiply imputed datasets from outside Mplus. That is, the missingness has already been taken care of outside of Mplus. I want to estimate my structural equation models on these X datasets and use Mplus to make the necessary corrections to the coefficient estimates and standard errors. How do I do this? Thanks.
 Linda K. Muthen posted on Monday, September 24, 2007 - 11:29 am
Use the IMPUTATION option of the DATA command.
 Rob White posted on Tuesday, September 25, 2007 - 12:51 pm
Thanks very much. One question: why do my MPlus standard errors differ from the standard errors I get from using the ice commands in Stata?

Mplus Stata
est. s.e. est. s.e.
-1.05 .025 -.1046 .0264
0.837 .089 .8370 .0945

Stata documentation indicates that it uses the same Rubin rules for correcting the errors as referenced in Schafer (1997). I've confirmed that the Stata calculation is correct with hand calculations. Is there some subtle difference I'm not understanding? Since I'm using Mplus to estimate only the model, rather than generate the MI data and estimate the model, the datasets are identical across both programs.
 Rob White posted on Tuesday, September 25, 2007 - 12:53 pm
Please note that there is a decimal error in the Stata estimate. -.1046 should actually read -1.046
 Rob White posted on Tuesday, September 25, 2007 - 1:09 pm
Also, are the corrected estimates and errors available in the output coming from SAVEDATA, RESULTS ARE ? I cannot find them in there. Thanks.
 Linda K. Muthen posted on Tuesday, September 25, 2007 - 1:34 pm
We would need to see the input, data, output, and your license number at support@statmodel.com to check this out. Please send also the Stata output and your hand calculations.

The estimates and standard errors should be saved. Send us the output where you ask for them to be saved and also the saved data set.
 Averdijk posted on Saturday, April 18, 2015 - 3:35 am
Dear Prof. Muthen,

I also generated multiply imputed data from outside MPlus and am trying to analyze them in MPlus (for a mediation analysis).
My imputed data sets are called 'imp1.dat', 'imp2.dat' etc.

I specified:

DATA: file is D:\implist.dat;
type = imputation;

But I get the following error: ' The file specified for the FILE option cannot be found. Check that this file exists: D:\implist.dat'

Could you perhaps advise?

Many thanks in advance.
 Linda K. Muthen posted on Saturday, April 18, 2015 - 5:54 am
Search for implist.dat to see if it is found. It may have a hidden extension.
 Averdijk posted on Saturday, April 18, 2015 - 12:08 pm
Many thanks for your answer. No, 'implist.dat' is not found by Windows Explorer. But 'implist.dat' does not exist, as I created separate files named 'imp1.dat', 'imp2.dat' etc. My understanding was that instead of specifying something like:

DATA: file is D:\imp1.dat, D:\imp2.dat

one would need to say:

DATA: file is D:\implist.dat

where MPlus would understand that the 'list' in 'implist' means '1', '2', etc. Is this not correct? If not, how do I instruct MPlus which files to use?
 Linda K. Muthen posted on Saturday, April 18, 2015 - 1:30 pm
You must have a file that contains the names of the data sets. See Example 13.13.
 Averdijk posted on Monday, April 20, 2015 - 5:00 am
Thanks a lot.
I now have a variable called 'implist' that contains the values 'imp1.dat', 'imp2.dat' etc. for each case. However, I still get error messages (a long list of 'Errors for replication' and 'the file cannot be found').
I experimented with different names for the values of 'implist' (e.g., 'imp1', 'imp2') and string and numerical versions, but get the same error message.
I tried calling the implist variable 'implist.dat', but this exceeds 8 characters.
When I omit 'type=imputation' I get no error Messages.

I am working with MPlus 6.1.
 Linda K. Muthen posted on Monday, April 20, 2015 - 6:23 am
You don't need a variable called implist. You need a data set that contains the names of the imputed data sets. Look at Example 13.13.
 Michelle Wu posted on Monday, February 05, 2018 - 11:59 am
Hi Linda,

Now I have a .dat file containing the following contents


But Mplus kept giving me the error message:
*** ERROR in DATA command
A data file for TYPE=MONTECARLO or TYPE=IMPUTATION cannot be found. Check that this file exists: /Users/US data/imp1.dat

Could you let me know how could I solve this? Thank you very much.
 Michelle Wu posted on Monday, February 05, 2018 - 12:02 pm
By the way, these five files were created and converted to Mplus readable format by Stata and each of them contained an imp*.inp in my source file. Could it be the problem with reading in the data in Mplus?

Thank you!
 Linda K. Muthen posted on Monday, February 05, 2018 - 1:36 pm
The data set names must be exactly the same as you show in the file specified using the FILE option. Be sure the path is correct also. If you can't see the problem, send the files and your license number to support@statmodel.com.
 Vivienne Hazzard posted on Thursday, January 30, 2020 - 12:36 pm
Similar to one of the posters above, I am trying to save the results with the SAVEDATA command and multiply imputed datasets, but the results only seem to be saved separately for each replication number. Is there a way to obtain the results for the results combined across replications through the SAVEDATA command?

Thank you!
 Tihomir Asparouhov posted on Thursday, January 30, 2020 - 3:24 pm
It will be available in the next version: Mplus 8.5.
 Vivienne Hazzard posted on Friday, January 31, 2020 - 11:04 am
Great, thank you!
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message