Error message multi-group PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
Message/Author
 Marike Deutz posted on Thursday, March 28, 2013 - 6:18 am
Dear Bengt and Linda Múthen,

I am conducting a multi-group CFA (2 groups: gender) and I get the following error messages:

*** ERROR
Group 1 does not contain all values of categorical variable: ITEM14
*** ERROR
Group 1 does not contain all values of categorical variable: ITEM31
*** ERROR
Group 1 does not contain all values of categorical variable: ITEM1

Both groups have scores on the two categories (0 and 1) for the three items mentioned in the error messages. 100% sure.

However, for girls there are also missings on these variables (1 for each item) while there are no missings for boys on these items. So it seems this should be the problem. However, I did indicate Missing are all (99).

How can I make the program work so I don't have to delete my 3 cases with only 1 missing score on an item? So how can the program work with missings on one group but not on the other?


Thank you!
 Linda K. Muthen posted on Thursday, March 28, 2013 - 7:25 am
It sounds like you are reading the data incorrectly. Please send the output, data, and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: