Error reading file for CFA PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
Message/Author
 Taylor Mefford posted on Tuesday, April 03, 2018 - 11:58 am
Hey, all! Taking a course on SEM, and I'm trying to run a CFA to make sure that six items all load on to one factor as they're supposed to. However, I'm getting the following error:

*** ERROR
The number of observations is 0. Check your data and format statement.
Data file: I:\Psychological WB CFA.csv
*** ERROR
Non-missing blank found in data file at record #1, field #: 2

I've checked the file. There are no blank spaces. As you can see, it's a CSV file. I removed the variable names when I converted from SAV. Where did I go wrong?
 Linda K. Muthen posted on Tuesday, April 03, 2018 - 12:23 pm
It sounds like you have blanks in the data set. This is not allowed with free format data. Check the record and field mentioned in the error message.
 Jesus Garcia posted on Friday, July 13, 2018 - 3:50 am
Hello everyone, I have a problem with my CFA analisys, the software Mplus show me the following text:
*** ERROR
The number of observations is 0. Check your data and format statement.
Data file: spss.dat
*** ERROR
Invalid symbol in data file:
"´╗┐" at record #: 1, field #: 1

My data set is from SPSS but I don┤t have any symbol in the first field. Can you help me?
 Linda K. Muthen posted on Friday, July 13, 2018 - 11:41 am
Open the data set in the Mplus Editor. You will see the symbol at the beginning of the data set. Remove it and resave the data.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: