CFA fit indices PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
Message/Author
 Liz Woodruff posted on Wednesday, May 25, 2011 - 2:01 pm
I ran a CFA "successfully" (i.e., there were no negative residual variances, or other error messages). Unfortunately, my fit indices are indicating lack of fit.

E.g.,
Chi-Square = 337.5 p = .000
RMSEA = .08
SRMR = .06

Do you have suggestions on how I might modify things to increase goodness of fit?
 Liz Woodruff posted on Wednesday, May 25, 2011 - 2:02 pm
For example, are there robust fit indices?
 Linda K. Muthen posted on Wednesday, May 25, 2011 - 2:05 pm
You can take a look at modification indices. Or you could start with an EFA to see if your CFA model is in the ballpark.

MLR is a robust to non-normality.
 Liz Woodruff posted on Wednesday, May 25, 2011 - 2:34 pm
OK, thank you. The SRMR = .06 and the literature (as you know) suggests a cutoff of SRMR </= .07/.08. Given that my model is below the cutoff on the SRMR, is it safe to consider it indicated, even though the other fit indices aren't as strong?

Thank you in advance.
 Linda K. Muthen posted on Wednesday, May 25, 2011 - 5:14 pm
If everything else is bad, I think you would have a hard time justifying looking at only SRMR.
 Liz Woodruff posted on Thursday, May 26, 2011 - 12:49 pm
OK, thank you. I am having a hard time understanding how to use modification indices in my analysis. I looked at the shortcourse video as well as the manual but I'm a bit confused.

First I used this command:
OUTPUT: STANDARDIZED MODINDICES (3.84) SAMPSTAT;

Then:
OUTPUT: MODINDICES (0);

OUTPUT: MODINDICES (ALL);

OUTPUT: MODINDICES (ALL 0);

But in truth, I'm not sure what the differences are between these or which is most appropriate for my data...each of these gives me the same results as the standardized output command, none of my fit indices change at all. Am I doing something wrong? Thank you for your patience and help.
 Liz Woodruff posted on Thursday, May 26, 2011 - 12:52 pm
Oh, I see! Model modification indices are where the results are given. Could you, however, still explain the difference between the types of modifications I mentioned above?

Thank you.
 Linda K. Muthen posted on Thursday, May 26, 2011 - 2:13 pm
This is explained in the user's guide. Please look there.
 Liz Woodruff posted on Tuesday, May 31, 2011 - 2:01 pm
OK, I believe that I understand which command to use. However, I am a bit confused in terms of interpreting the modification indices.

E.g., The command I used was STANDARDIZED MODINDICES (3.84); Below is an example of one of the modification indices provided:

M.I. EPC StdEPC StdYXEPC

F1 BY Y9 (MI)39.504
(EPC).180
(StdEPC).031
(StdYXEPC).362

Does this mean that by setting Y9 at 3.84 then chi-squared drops by 39.504?
 Linda K. Muthen posted on Tuesday, May 31, 2011 - 2:14 pm
No, this means that by freeing the factor loading of y9 for f1, chi-square will drop by 39.504.
 Liz Woodruff posted on Wednesday, June 01, 2011 - 2:50 pm
I have found that adding a residual covariance between to indicators will improve my chi-squared. Is there a portion of the short course video or a place in the manual that will instruct me on how to add this covariance?

Thank you
 Liz Woodruff posted on Wednesday, June 01, 2011 - 2:51 pm
*two indicators:-)
 Linda K. Muthen posted on Wednesday, June 01, 2011 - 3:12 pm
See the WITH option in the user's guide. Chapter 17 of the user's guide documents the MODEL command. This is an important chapter to be familiar with.
 Liz Woodruff posted on Thursday, June 02, 2011 - 2:28 pm
I have a feeling I know what you will say, but do you have suggestions for how to proceed if modification indices do not satisfactorily improve the model's fit to the data?
 Linda K. Muthen posted on Thursday, June 02, 2011 - 2:48 pm
If you are looking at a CFA, I would suggest starting with an EFA to see if your CFA was even in the ballpark.
 Liz Woodruff posted on Friday, June 03, 2011 - 10:36 am
Is it possible to run a "mini" CFA for each individual latent construct? To look at the factor loadings separately from the entire model?
 Linda K. Muthen posted on Friday, June 03, 2011 - 10:38 am
Yes, you can and should test submodels. You can do this only if a factor has more then three indicators.
 Malte Jansen posted on Thursday, February 14, 2013 - 8:55 am
Dear Mplus Team,

i have run a CFA model with 18 Items loading on one latent factor. This is just a comparison model for the model that follows from our theoretical hypothesis and the questionnaire scales(a three dimensional model with 6 items on each factor), so the fit of the model is supposed to be rather bad. A three dimensional model with moderate correlations (.3 to .5) actually provided a good fit to the data.

However, the fit of the one-dimensional comparison model turned out to be so bad that i started wondering if these numbers are even possible:


Chi-Square: 13338
MLR Scaling Correction: 0.142
RMSEA: 0.505
CFI: 0.000
TLI: -4.2
SRMR: 0.194
(n is 384 and df are 135).

I already checked for possible errors in the data. I checked some SEM/CFA literature but most did not mention CFI values of zero or such a low MLR scaling correction factor as possible cases. Also, the Chi-Sqaure is worse than the Chi-Square of the Baseline Model (7737.047, df = 135). Is there any chance that these numbers are trustworthy? It would be great if you could help me.
 Linda K. Muthen posted on Thursday, February 14, 2013 - 1:41 pm
This could be caused by very low correlations in your data. I would check that.
 Malte Jansen posted on Friday, February 15, 2013 - 5:55 am
Well, theoretically the items are supposed to load on three independent factors (the one factor model is a comparison model that follows from a different theory) with 6 items each. Within each of the three factors, the manifest correlations between the indicators are ~ 6. to .7. Across factors the manifest correlations are ~ .15 to .35, so, yes they are very low for a one factor model.

However, even given these low correlations, how is a Chi-Square value worse than the value of the baseline model and a negative TLI possible?

Best regards,
Malte
 Linda K. Muthen posted on Friday, February 15, 2013 - 10:41 am
When a model fits so poorly, odd things can happen.
 Kara Thompson posted on Friday, January 03, 2014 - 3:30 pm
I am running a CFA with 5 indicators. some of the indicators are the same construct measured at two different time points (i.e., alcohol T1 and alcohol T2). The loadings are great (all >.60), but the fit is terrible - particularly the RMSEA. All variables are significantly correlated. Why are the loadings and model fit so inconsistent with each other?

Thanks
Kara
 Linda K. Muthen posted on Saturday, January 04, 2014 - 12:59 pm
The size of the factor loadings is not related to fit. It may be that the two repeated measures are correlated so highly they need more than one factor. You may want to post a general question like this on a general discussion forum like SEMNET.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: