MPLUS error message PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
Message/Author
 brendadooley posted on Sunday, May 06, 2012 - 8:26 am
Linda

I received the following MPLUS warning
THE MODEL ESTIMATION DID NOT TERMINATE NORMALLY DUE TO AN ILL-CONDITIONED
FISHER INFORMATION MATRIX. CHANGE YOUR MODEL AND/OR STARTING VALUES.

THE MODEL ESTIMATION DID NOT TERMINATE NORMALLY DUE TO A NON-POSITIVE
DEFINITE FISHER INFORMATION MATRIX. THIS MAY BE DUE TO THE STARTING VALUES
BUT MAY ALSO BE AN INDICATION OF MODEL NONIDENTIFICATION. THE CONDITION
NUMBER IS -0.144D-19.

THE STANDARD ERRORS OF THE MODEL PARAMETER ESTIMATES COULD NOT BE
COMPUTED. THIS IS OFTEN DUE TO THE STARTING VALUES BUT MAY ALSO BE
AN INDICATION OF MODEL NONIDENTIFICATION. CHANGE YOUR MODEL AND/OR
STARTING VALUES. PROBLEM INVOLVING PARAMETER 28.

What can I do to fix this?
 Linda K. Muthen posted on Sunday, May 06, 2012 - 8:53 am
Please send the output and your license number to support@statmodel.com.
 brenda posted on Tuesday, May 08, 2012 - 2:35 am
Linda

I have tried to set the residual variance using RF60t1@0; The residual variance is set to zero in output once the code is re ran. However the same message comes back involving parametre 28

I assume that the parametre number is found under tech 1 - parametre specification for between. The residual variance for this parametre is .008 before it was set to zero

Thanks
 Linda K. Muthen posted on Tuesday, May 08, 2012 - 5:53 am
Please send the output and your license number to support@statmodel.com.
 A. Dickison posted on Tuesday, May 22, 2018 - 8:14 am
Hello,

Cases were being dropped in my path model, so I added in a line of code to estimate the means and variances of my 3 exogenous variables.

When I run tests of moderation, I receive a warning error after the statement of the model has terminated normally, "The standard errors of the model parameter estimates may not be trustworthy for some parameters due to a non-positive definite first-order derivative product matrix..."which I did not receive when I did not have this line of code.

MODEL:
t2a ON t2d;
t2a ON t2p;
t2a ON t2pu;
t2a1 ON t1di;
t2d ON t2s;
t2d ON t2p;
t2s ON t2p;
t2p ON t2m;
t1di t2pu t2m;

MODEL A:
t2a ON t2d;
t2a ON t2p;
t2a ON t2pu;
t2a1 ON t1di;
t2d ON t2s;
t2d ON t2p (a1);
t2s ON t2p;
t2p ON t2m;
t1di t2pu t2m;

MODEL B:
t2a ON t2d;
t2a ON t2p;
t2a ON t2pu;
t2a1 ON t1di;
t2d ON t2s;
t2d ON t2p (a2);
t2s ON t2p;
t2p ON t2m;
t1di t2pu t2m;

Model Indirect:
t2a IND t2p;
t2d IND t2p;
t2a IND t2m;
t2d IND t2m;

MODEL TEST:
0=a1-a2;

Thank you!
 Bengt O. Muthen posted on Tuesday, May 22, 2018 - 5:49 pm
If the exogenous variable is binary, you can ignore the message.
 A. Dickison posted on Wednesday, May 23, 2018 - 11:54 am
Hi Bengt,

Thank you for your response. The variable that is indicated as a problem in the error message is binary. The other two are continuous.

Is there a way to correct for participants being dropped from the analysis on a grouping variable? I am assuming there is not, if I do not know what group they belong to?

Thank you!
AD
 Bengt O. Muthen posted on Thursday, May 24, 2018 - 3:41 pm
Are you saying that you have missing data on a Grouping variable or a binary covariate? For the latter, see the Topic 11 Short Course YouTube video on our website.
 A. Dickison posted on Thursday, May 24, 2018 - 4:50 pm
Hi Bengt,

Thank you for the response, and I apologize for the confusion. They are two separate questions/problems.

When I had missing data in my model on 3 exogenous variables, so I added in a line of code for my 3 exogenous variables, which brought in all my cases. Then when I ran tests of moderation, I received the above warning message that I did not receive before I added in that line of code. The warning message pointed to a binary covariate as the problem. I think that I am all squared away on this problem in that I can ignore that message.

Additionally, when I run tests of moderation and use the grouping command I receive this error message: Data set contains unknown or missing values for "GROUPING,PATTERN, COHORT, CLUSTER and/or STRATIFICATION variables.Number of cases with unknown or missing values: 5." I am assuming there is not much I can do about this considering I do not know what group they belong to?

Thanks for the resource and assistance!
Best/AD
 Bengt O. Muthen posted on Thursday, May 24, 2018 - 5:12 pm
Right; unless you change to having the grouping variable as a binary dummy variable and include it with the other exogenous variables which will then help to "impute" the missing data on the grouping dummy (although there may not be enough information to do that well). The covariate approach to multiple groups of course provides less flexible modeling.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: