Problems with LCA with covariates PreviousNext
Mplus Discussion > Latent Variable Mixture Modeling >
Message/Author
 Raheem Paxton posted on Thursday, November 09, 2006 - 11:42 pm
Hi,

Running into a problem with my analysis. For some strange reason its taking for ever to run. Can you tell me what I am doing wrong. Would it be easier if the covariates were binary.

USEV ARE a-z

CATEGORICAL ARE x z;


MISSING = ALL (9);
CLASSES = C (5);


ANALYSIS: TYPE = MIXTURE MISSING;
ALGORITHM=INTEGRATION;
INTEGRATION = MONTE;

!STARTS = 100 10;
ModEL:

%OVERALL%

C#1-C#4 ON x y z;

Thanks
 Raheem Paxton posted on Thursday, November 09, 2006 - 11:51 pm
I ran a LCA and it revealed 5 classes. Can I add the covariates and predict distal outcomes all in the same model.

ANALYSIS: TYPE = MIXTURE MISSING;
ALGORITHM=INTEGRATION;
INTEGRATION = MONTE;

!STARTS = 100 10;
ModEL:

%OVERALL%

C#1-C#4 ON x y z;
prostate on c#1-C#4;
 Linda K. Muthen posted on Friday, November 10, 2006 - 12:06 am
In your first post, you need to remove the covariates from the CATEGORICAL list.

In the second post, yes, you can add covariates and distal outcomes.

If you have questions related to the Mplus language, please send them along with your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: