Cannot get DIFFTEST to work PreviousNext
Mplus Discussion > Categorical Data Modeling >
Message/Author
 andy supple posted on Thursday, December 01, 2011 - 7:33 pm
I am trying to use the DIFFTEST to compare models with categorical indicators. I get an error telling me that my models are not nested and I can't understand why.

The first model I run is (truncated code so I don't go over the message size limit)

grouping is group (1=white, 2=latino, 3=arm);
missing are all (-999);
analysis:
type is general;
estimator is wlsmv;
model:
F1 by dothing quality worth positiv satisfy resteem1 resteem2 resteem5 resteem9 resteem0;
F1@1;
model white:
F1 by dothing quality worth positiv satisfy resteem1 resteem2 resteem5 resteem9 resteem0;
F1@1;
model latino:
F1 by dothing quality worth positiv satisfy resteem1 resteem2 resteem5 resteem9 resteem0;
F1@1;
model arm:
F1 by dothing quality worth positiv satisfy resteem1 resteem2 resteem5 resteem9 resteem0;
F1@1;
savedata:
file is derivmodel1;
output: modindices standardized;

grouping is group (1=white, 2=latino, 3=arm);
missing are all (-999);
analysis:
type is general;
estimator is wlsmv;
difftest is derivmodel1;
model:
F1 by dothing quality worth positiv satisfy resteem1 resteem2 resteem5 resteem9 resteem0;
F1@1;
output: modindices standardized;
 Linda K. Muthen posted on Thursday, December 01, 2011 - 9:08 pm
Please send the two relevant outputs and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: