Estimator in MPlus PreviousNext
Mplus Discussion > Exploratory Factor Analysis >
Message/Author
 Seán Delaney posted on Friday, March 21, 2008 - 5:07 pm
Hi, I am studying two sets of data (survey responses to the same set of questions from respondents in 2 different countries). Prior to conducting multiple group sampling, I wanted to use EFA to study the factors that emerged in each set of data. I specified Promax rotation and ULS as the estimator for each set of data. However, in one dataset the data were analyzed using ULS as the estimator (and no Chi Square estimates were given). When estimating the factors of the other dataset, MPlus changed the estimator to WLSM.

I am not sure why it did this because the command files seem similar in every other way. The data files also seem identical (One dataset has more responses than the other). Does the different estimators make a difference for presenting the data side by side in a paper? (I know that they cannot be compared directly without using target rotation). Is it possible to insist that MPlus uses ULS for both or should I change the estimator for the first data set to WLSM?

Thanks,

Sean
 Linda K. Muthen posted on Friday, March 21, 2008 - 5:15 pm
If everything else is identical, I don't think Mplus would use different estimators. Please send the two full outputs and your license number to support@statmodel.com.

You should use the same estimator.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: