Knownclass + class labelling PreviousNext
Mplus Discussion > Latent Variable Mixture Modeling >
 Jon Heron posted on Monday, July 14, 2014 - 8:16 am
Hi Bengt/Linda

I'm fitting a mixture model with a both a latent class and a knownclass.

In example 7.21, "model c:" and "model cg:" are used to specify the constituent parts of the model. One can then refer to %c#1% and %cg#1% rather than using the alternative %cg#1.c#1% approach.

Is there a way of using both labelling conventions in the same model? i.e. I would like a section defined using %cg#1.c#1% and then another section defined using %cg#1%.

I've tried a few things and nothing seems to work.

many thanks, Jon
 Jon Heron posted on Tuesday, July 15, 2014 - 12:06 am
To give a bit more info on what I'm trying to do, I am modelling a GMM for boys and girls in tandem. Some classes are invariant between the sexes. To define this requires the %sex#1.c#1% notation.

I then wish to regress the classes on a covariate, obtaining regression estimates for boys and girls separately so I can use model constraint to estimate the difference in the effect my covariate has on the invariant classes. Seems to me that this needs a %sex#1% and %sex#2% approach.
 Bengt O. Muthen posted on Tuesday, July 15, 2014 - 9:43 am
You can use both MODEL c1 and MODEL c1.c2 in the same input. But careful consideration should be used for the parameters given in these models that will not lead to confusion. For example, mentioning [ y ] in

[ y ]
MODEL c1.c2:
[ y ]
would lead to confusion.
 Jon Heron posted on Tuesday, July 15, 2014 - 11:29 am
Thanks Bengt

I tried a variant of that but perhaps gave up too soon when I got an error.
I'll experiment a bit more now I know that way is possible

cheers, Jon
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message