Variables associated with LTA PreviousNext
Mplus Discussion > Latent Variable Mixture Modeling >
Message/Author
 Tracy M Carter posted on Monday, January 05, 2015 - 12:07 pm
Hi - I posted a question in Dec. & now have some follow up questions. I tried posting in the original thread but got an error message so I'm starting a new thread here.

My question is this: I ran the model for the continuous covariate associated with the transition probabilities. The user guide refers to an LTA calculator from the Mplus menu of the Mplus Editor to calculate the latent transition probabilities for different values of the covariate.

I'm not sure where to find this calculator - I've looked through all the drop down menu's on my Mplus Editor and can't seem to find any calculators. Any more specific instructions on where to find this/how to calculate?

Also, I ran models for the dichotomous covariates but was only able to include 1 covariate at a time. Is it possible to run 1 model and include all 3 dichotomous covariates of interest? Would it also be possible to run 1 model with all covariates (continuous and dichotomous)?

Thank you!

Original post:
I'm conducting an LTA with 2 time points (fall & spring of a preschool year). I want to examine variables associated with children's movement across the year. What types of analyses are possible to answer this question?

Dr. Muthen suggested I look at examples 8.13 & 8.14 in the user's guide.
 Bengt O. Muthen posted on Monday, January 05, 2015 - 5:17 pm
The location of the calculator is shown on slide 80 in the handout "V7Part2" of our Utrecht August 2012 video and handout on our website:

http://www.statmodel.com/course_materials.shtml

It should be no problem to run several covariates at a time.
 Tracy M Carter posted on Tuesday, January 06, 2015 - 7:27 am
When I try to run multiple covariates together I get an error message that reads:
"Multiple KNOWNCLASS specifications detected. Only one KNOWNCLASS variable is allowed."

I also do not have the LTA Calculator option in my drop down menu as indicated in the screen shot of slide 80 in the handout V7Part2 from Utrecht. I'm using Mplus7 - any ideas why this is not available for me? Or alternative options for calculating?

Thanks
 Bengt O. Muthen posted on Tuesday, January 06, 2015 - 1:42 pm
If you have several categorical covariates and want to use the TECH15 calculator you have to create a new variable that is the combination of them (e.g. black female,...., while male).

Perhaps you don't have a PLOT command in your input.
 Hye Jeong Choi posted on Thursday, January 15, 2015 - 10:54 am
Is it possible to include time-varying covariates and time-invariant covariates both in LTA model? If so, what should I do?

Thank you.
 Bengt O. Muthen posted on Thursday, January 15, 2015 - 11:31 am
For 2 times points, try saying:

c1 c2 on tic;
c1 on tvc1;
c2 on tvc2;
 Hye Jeong Choi posted on Sunday, October 25, 2015 - 11:48 am
I am doing LTA with binary co-variate. I am using w2, 3 & 4 and 5 classes.

I got messages:

ONE OR MORE MULTINOMIAL LOGIT PARAMETERS WERE FIXED TO AVOID SINGULARITY
OF THE INFORMATION MATRIX. THE SINGULARITY IS MOST LIKELY BECAUSE THE
MODEL IS NOT IDENTIFIED, OR BECAUSE OF EMPTY CELLS IN THE JOINT
DISTRIBUTION OF THE CATEGORICAL LATENT VARIABLES AND ANY INDEPENDENT
VARIABLES. THE FOLLOWING PARAMETERS WERE FIXED:
Parameter 96, MODEL CG: %CG#1%: C3#4 ON C2#3
Parameter 115, MODEL CG: %CG#2%: C3#3 ON C2#4

I checked their transition probabilities. Transition probability from c2#3(w2 class3) to c3#4 (w3 class4) was .16 whereas from c2#3 (W2 class3) to c3#5 (w3 class5) was 0.

What I understood is that if transition probability from w2 class3 to w3 class4 is 0, then the model is OK given the "warning messages". (aka, I do not need to modify my model any more.)

My current model should be changed because the transition probability is not 0 from w2 class3 to w3 class4 but transition probability from w2 class3 to w3 class5 is 0?
As far as I understood, last class' transition probability is not estimated because it served as "reference" Thus, is it ok to not-to-change the current model?

Thank you for advice in advance.
 Linda K. Muthen posted on Monday, October 26, 2015 - 9:21 am
Look at the logits for the two parameters mentioned. If you cannot see the issue, please send the output and your license number to support@statmodel.com.
 Hye Jeong Choi posted on Monday, October 26, 2015 - 12:46 pm
I saw the issue but not sure how to fix it.

Should I decrease the number of classes?
What would you suggest?

Again, thank you.
 Bengt O. Muthen posted on Monday, October 26, 2015 - 3:47 pm
If the logits are big in absolute value for the parameters mentioned there is nothing that needs fixing.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: