Lgm with missing data PreviousNext
Mplus Discussion > Growth Modeling of Longitudinal Data >
Message/Author
 Daniel Rodriguez posted on Thursday, May 04, 2006 - 7:03 am
I am running an LGM with the analysis command, type = meanstructure missing h1;
You once mentioned it is possible to set the program so that all available data applies to the dependent variables only instead of all variables. Now, my sample size is based on all data, including covariates. I'd like to restrict it to the dependent measure only. How do I do this?
 Linda K. Muthen posted on Thursday, May 04, 2006 - 2:27 pm
If you are saying that you want to delete cases with missing values on covariates, use TYPE=MISSING RANDOM;
 Daniel Rodriguez posted on Wednesday, August 09, 2006 - 7:58 am
Hi,
I ran the model with type=Missing random and all is well. One question, I did not get standardized values. Is there a way to get standardized values for my figure using Type=Missing random?
 Linda K. Muthen posted on Wednesday, August 09, 2006 - 8:58 am
Did you ask for STANDARDIZED in the OUTPUT command? If so and you don't get standardized values, then they aren't available for your model.
 Daniel Rodriguez posted on Wednesday, August 09, 2006 - 9:36 am
Yes, I asked for STANDARDIZED in the output command, but I got the following warning.

*** WARNING in Output command
STANDARDIZED option is not available for analysis with
TYPE = RANDOM. Request for STANDARDIZED is ignored.
 Annie Desrosiers posted on Monday, October 02, 2006 - 5:43 am
Hi, I'm from Quebec, so sorry for my accent!!
I'm trying to use MPlus, It's new for me.
I'm doing growth modelin on a variable censored from de bottom at three times non-regular. What i want is the intercept and the slope for everybody.
I did it with SPSS ans SAS and I got a intercept arround 12 and a positive slope, that it's normal, in know my data and It's for sure positive across time.

The problem is that I want to work with MPlus but with this input i got a negative slope??

Thank you

variable: names are sexe age1-age3 y1-y3 a1-a3;
usevariables are age1-age3 y1-y3;
tscores = age1-age3;
censored are y1-y3 (b);

analysis: type = random missing;
estimator = ml;

model: i s | y1-y3 at age1-age3;
 Bengt O. Muthen posted on Monday, October 02, 2006 - 2:47 pm
If you have done type = basic to check that your descriptive statistics are correct (variables are in the right columns in the data matrix), then please send your input, output, data and license number to support@statmodel.com.
 Annie Desrosiers posted on Tuesday, October 03, 2006 - 3:46 am
I found the problem...
I did not know that when I put type = missing, I have to tell what is the missing (missing=.)
Now it's working well!!
But, I have another question about plot.
I made the plot of individual growth and I can see 10 individuals at a time.
How a can plot the regression that MPlus give in the output. And, is it possible to have a plot for the two regression, one for each gender? I whant to see at the same time the model for female and the model for male in a graph.

Thank you
 Bengt O. Muthen posted on Tuesday, October 03, 2006 - 2:29 pm
Use

Plot:

type = plot3;

and use the menu options "Estimated means", or "Adjusted estimated means".
 Annie Desrosiers posted on Wednesday, October 04, 2006 - 5:19 am
Hi, thank you for your time.
With the type = plot3, I can see just 3 choices...
Histogram
Scatterplot
Observed individual values
And in none of these, I see a menu options.

Annie
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: