AR cross-lagged model with binary var... PreviousNext
Mplus Discussion > Categorical Data Modeling >
Message/Author
 kloud posted on Friday, March 10, 2017 - 8:57 am
Dear Prof Muthén,

I’m trying to run an autoregressive cross-lagged model with two time-series variables measured at 3 timepoints.
One is continuous(M1-M3) and the other(TR1-TR3) is binary(I set TR2 and 3 to be categorical), and both variables have missing at some points.
The model is as below.

ANALYSIS: TYPE is general;
Estimator is MLF;
integration = montecarlo;

Model:
M_1 on TR1;
M_2 on TR2;
M_3 on TR3;
M_2 on M_1;
M_3 on M_2;
TR2 on TR1;
TR3 on TR2;
TR2 on M_1;
TR3 on M_2;

1. Mplus do not provide fit indices such as chi-square, TLI, CFI, and RMSEA for this model.In this case, how can I judge the goodness of fit of this model? Is there any alternative way to see its fit, instead? (not comparison with other models)

2. Second, I was not able to obtain the standardized coefficients, as well.It seems that Mplus suggests of models with categorical variables(using TECH10).But I got a message like this.

TECH10 OUTPUT FOR CATEGORICAL VARIABLES IS NOT AVAILABLE FOR MODELS WITH COVARIATES.

Is there no way to compare the effect of two variables?
for example, TR2 on TR1 and M_1(like logistic reg)
Thank you for reading.
 Bengt O. Muthen posted on Friday, March 10, 2017 - 6:23 pm
I would switch to Estimator = WLSMV or Bayes.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: