EFA in version 7 versus Version 5 PreviousNext
Mplus Discussion > Exploratory Factor Analysis >
 Claire Gorey posted on Wednesday, August 06, 2014 - 8:33 am
I ran a categorical EFA in version 7 at my previous institution using the WLSMV estimator and quartimin rotation. I had strong factor loadings and very good model fit for the four factor solution. However, I change institutions, and they only have mplus version 5 available. When I re-ran this in mplus version 5 on the same data and using the same code, I got the same factor loadings but now my model fit was not good at all (i.e., CFI went from .97 to .90....a very big change). I am very curious as to what changed between versions to cause this?? Also, would I have the same problem if I use classic FA estimators that aren't using polychoric correlations?? Any insight you could provide on this would be helpful. I will probably just buy the updated version but am interested to have an explanation, as I would think model fit calculations should not have changed.
 Linda K. Muthen posted on Wednesday, August 06, 2014 - 9:17 am
A new adjustment to chi-square was introduced in Version 6. It is asymptotically equivalent to the previous one but results in regular degrees of freedom. You can find the explanation in the Version 6 Technical Appendix

Simple second order chi-square correction

Only WLSMV is affected.
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message