Multiple regression vs SEM PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 Jennifer Clark posted on Monday, March 11, 2013 - 9:40 am
Hi
I am getting very different results when I compare a regular regression model testing for mediation with an SEM model.

I conducted EFAs in STATA and then predicted the factor scores to make: IV1, M1, and DV1. I then tested the traditional Baron & Kenny mediational analysis (i.e. regress DV1 on IV1, then regress DV1 on M1 & M1 on IV1, finally regress DV1 on IV1 with M1 in the model). In the final regression the inclusion of M1 attenuates the coefficient of IV1 on DV1, but it still has a positive value, as it did in the non-mediated regression. This was the same result I got when I exported latent factor scores from Mplus to STATA.

However, when I run the same 3 way model as an SEM using latent variables in Mplus (WLSMV estimator since observed dependent indicators are categorical; and I first tested CFAs of each latent factor which all had great fit), the remaining direct effect from IV1 to DV1 switches from positive to negative when M1 is included in the model. The output shows the indirect effect of IV1 to M1 to DV1 is greater than the independent direct effect of IV1 and DV1. I tried checking listwise/pairwise analyses in both Mplus and STATA and it didnít change anything.

So I'm wondering why I'm getting contrasting results? Are the 2 analyses doing something different statistically?

Thank you for any advice you can provide; this question has stumped everyone here.
 Linda K. Muthen posted on Monday, March 11, 2013 - 11:01 am
It's hard to understand exactly what you are doing. Please send the two outputs and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: