Some latent variables are correlated PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 Delfino posted on Monday, May 13, 2002 - 1:49 pm
I have structural model where y=beta*x+lambda*u, and z=delta*u+error. Where y is an observed outcome, x's are observed sociodemographic characteristics, u are latent variables observed from z's. I have 4 latent variables u and the structure of correlation between the u's ranges from .02 to .70. If for the latent variables u I free the correlation that are higher than 0.60 and fix to zero the remaining ones Can I rely on the estimates? Do I have collinearity problems?
 bmuthen posted on Tuesday, May 14, 2002 - 8:39 pm
You don't necessarily have collinearity problems, but it seems that it would be an empirical matter to check this out, perhaps by adding one factor (and its indicators) at a time into the y equation. You could also try to lower the factor correlations, perhaps by allowing a less restrictive loading matrix and residual covariance structure. You may also want to consult SEMNET with this type of question.
 Anonymous posted on Thursday, June 27, 2002 - 6:02 pm
I've run a SEM with categorical mediating variables, which I've had Mplus treat as latent continuous variables. The correlations between several of the error terms are small and insignficant and I'm considering fixing them to
zero.

How strong an assumption is that the correlations between error terms for latent variables is zero ?
Should the error terms always be allowed to be freely correlated if they've been modeled as having the same x variables ?
 bmuthen posted on Thursday, June 27, 2002 - 6:22 pm
Unless theory postulates otherwise, my personal feeling is that residual correlations among dependent variables should be included. If they are insignificant, fine; let's keep them anyway and report them as insignificant, meaning that any left-out predictors are uncorrelated.
 Mary Campa posted on Wednesday, March 23, 2005 - 5:51 pm
Is there any paper that talks about including residual correlations among dvs; both the justification and exactly what is happening??

I have a situation where I have included the residual correlations among dvs and even though they are not significant including them makes the standard error of the estimates change dramatically.

I have three dvs, two of which are mediating the third, and it is these regression standard errors that are changing.

Any help /reference would be greatly appreciated.

Thank you.
 BMuthen posted on Wednesday, March 23, 2005 - 10:46 pm
No reference comes to mind although I'm sure books like Bollen's SEM book discuss correlated errors. Generally speaking, allowing for residual correlations channels some of the correlations between variables through the residuals and therefore can alter the regression relationships between the variables and their standard errors. In a situation like you describe, it appears that your model is sensitive to minor changes and may be less likely to be replicated in a new sample.
 Michelle Shuler posted on Thursday, October 02, 2008 - 4:46 pm
I am running an SEM with continuous latent variables (the IV's and 3 DVs where the first two are mediators. Two of the IVs are highly correlated which seem to cause the estimates to go crazy. Is this correlation also causing the issues with the variances and residuals as well as the undefined R-square results?


Variances
T 1.000 0.000 999.000 999.000
C 1.000 0.000 999.000 999.000
R 1.000 0.000 999.000 999.000

Residual Variances
ETH 999.000 999.000 999.000 999.000
TR 0.351 0.284 1.237 0.216
INTER 0.556 0.108 5.138 0.000


Latent Variable

ETH Undefined 0.13257E+01
TR 0.649 0.284 2.290 0.022
INTER 0.444 0.108 4.101 0.000
 Linda K. Muthen posted on Friday, October 03, 2008 - 3:44 pm
The r-square for eth is undefined because the residual variance of eth was not able to be estimated. If you send your output and license number to support@statmodel.com, I can see why that happened.
 naT posted on Thursday, July 02, 2009 - 10:35 pm
I ran SEM model including one latent variable (F1) and there was a warning which said;
THE LATENT VARIABLE COVARIANCE MATRIX(PSI) IS NOT POSITIVE DEFINITE. THIS COULD INDICATE A NEGATIVE VARIANCE/RESIDUAL VARIANCE FOR A LATENT VARIABLE, A CORRELATION GREATER OR EQUAL TO ONE BETWEEN TWO LATENT VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE THAN TWO LATENT VARIABLES.CHECK THE TECH4 OUTPUT FOR MORE INFORMATION. PROBLEM INVOLVING VARIABLE "y1".

Could you help me understand what is going on here? The model is as follows.

x1 WITH x2@0;
F1@1;
F1 WITH x1@0;
F1 WITH x2@0;
F1 BY y1 y2(1);
y1 ON x1 x2;
y2 ON x1 x2;
y3 ON x1 x2 y2;
y4 ON x1 x2 y1 y2 F1;

x1, x2, y1, y2, y3, y4 are all observed continuous variable except for y2 which is observed dummy variable.

Thank you very much for your time in advance!
 Linda K. Muthen posted on Thursday, July 02, 2009 - 11:29 pm
See the results in your output. I suspect y1 has a negative residual variance which makes the model inadmissible. You need to change the model. If this is not it, please send the full output and your license number to support@statmodel.com.
 Jason Pierce posted on Wednesday, August 05, 2009 - 12:34 pm
Hi,

I added a latent variable to my model to confirm convergent validity of a second order construct. Now, I get the same message that "THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE DEFINITE." Indeed, two correlations have absolute values are greater than one:


MAS2 WITH
FEM -1.781 0.761 -2.339 0.019

ACHV WITH
FEM 0.877 0.490 1.791 0.073
MAS2 3.742 1.123 3.332 0.001

I have tried make minor changes to the model, but feel like I'm shooting in the dark. What ordinarily causes this to happen? And do you have any general recommendations or references that would guide me to a solution?

Thank you,
Jason Pierce
 Linda K. Muthen posted on Wednesday, August 05, 2009 - 5:31 pm
I don't understand how adding a latent variable confirms convergent validity.

This error message typically implies that the model is misspecified.
 kanako ishida posted on Tuesday, January 12, 2010 - 5:33 pm
Hello,
I am doing simultaneous estimation modeling of three equations like this;


f1 by Y1;
f2 by Y2;
f3 by Y3;
f1 ON X1 X2 X3;
f2 ON X1;
f3 ON X# X3;
f1 with f2;
f2 with f3;
f1@1;
f2@1;
f3@1;

where I don't want f1 to be correlated with f3, but by defalt, they are. How can I free this contraint?

Thanks!
Kanako
 Linda K. Muthen posted on Tuesday, January 12, 2010 - 5:47 pm
f1 WITH f3@0;
 kanako ishida posted on Tuesday, January 12, 2010 - 6:05 pm
Thanks!
 Maren Winkler posted on Thursday, April 01, 2010 - 8:14 pm
Hi,
I'm unsure whether I have specified my model correctly.
I have three latent variables x, y and z. I regress y and x on z and want to estimate the residual covariance between y and x when having accounted for the common variance they share with z.

I've specified the model as follows:
y ON z;
x ON z;
y WITH x;

Is this correct? Thanks for your help!
 Linda K. Muthen posted on Thursday, April 01, 2010 - 9:00 pm
This looks correct.
 Maren Winkler posted on Friday, April 16, 2010 - 4:46 pm
Hi,
I've got an additional question about residuals.
I have four indicators on the predictor side which all load one latent variable F1 - three tests (a, b and c) and HSGPA (d).
On the criterion side I have three indicators which are all grades (x, y and z) and load one latent variable F2.

I want to regress F2 on F1. I expect an additional "methods effect" from indicator d which I would estimate as a path from d's residual to F2.

I've specified a model as follows:

F1 BY a b c d;
F2 BY x y z;
F2 ON F1 d;

Is this correct? Thanks for your help!
 Bengt O. Muthen posted on Saturday, April 17, 2010 - 9:48 pm
Your statement regresses F2 on the whole variable d. To regress F2 on the residual of d you have to define the residual as a factor:

res BY;

together with

res WITH F1-F2@0;

and then get the loading of

F1 BY d;

as

res on F1;

plus delete the usual residual for d by saying

d@0;

Then you can say

F2 ON F1 res;
 Maren Winkler posted on Monday, April 19, 2010 - 7:05 am
Dear Mr. Muthén,

I've specified my model as follows now:

F1 BY a b c;
F2 BY x y z;

res BY d;
res WITH F1@0;
res WITH F2@0;

res ON F1;
d@0;

F2 ON F1 res;

I'm a bit confused about my results.

The path for res ON F1 is .183 (unstandardized) in the model above and .213 (unstandardized) in a model where F2 is only regressed on F1.

What confuses me even more is that the path for F2 ON F1 changes a lot depending on whether I add res as an additional predictor or not.
As I understand it, the variance of d that is explained by F1 is the same in both models. Hence, F1 is defined in the same way in both models. What I add in model 1 is the path from the residual of d on F2. Why does that change the relation between F1 and F2? Why would the path for F2 ON F1 get smaller when F2 ON res is added - actually getting smaller than the latter?

Have I specified something in a wrong way when establishing my model? Or am I overlooking some important point?
Thanks for your help, it's very much appreciated!
 Bengt O. Muthen posted on Monday, April 19, 2010 - 1:52 pm
Please send your input, output, and data to support@statmodel.com.
 Geehong Hyun posted on Thursday, January 23, 2014 - 7:41 pm
Dear Dr. Muthen,

I am doing the model below, but I am wondering if I should enter last statemnet of [variables] or not.
Because MPLUS gives different results depending on the statement is or not.

ANALYSIS: TYPE IS COMPLEX ;
ESTIMATOR IS MLR ;

MODEL: W3AWC ON COND W1AWC ;
W3AQ ON W3AWC W1AQ ;
W5MJ ON W3AQ W1MJ ;

W1AWC BY Y1AWC (1) ;
W1AWC BY P1AWC (2) ;
W3AWC BY Y3AWC (3) ;
W3AWC BY P3AWC (4) ;
- ..... -

W3AWC@0 W3AQ@0 ;

COND WITH W1AWC@0 ;
COND WITH W1AQ@0 ;
COND WITH W1MJ@0 ;

[Y1AWC P1AWC Y1XAQ X1AQ Y3AWC P3AWC Y3XAQ X3AQ] ;

Thanks a lot.
 Linda K. Muthen posted on Thursday, January 23, 2014 - 8:26 pm
Please send the two outputs and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: