Bayes SEM fatal error PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 David Markland posted on Thursday, December 05, 2013 - 8:36 am
Hello,
I am trying to run a structural model with latent variables (but with one exogenous observed variable), with Bayes estimation and zero mean small variance priors on cross loadings and residual covariances in the measurement model. The observed variables are standardized.
I am getting the fatal error:
THE PRIOR SPECIFICATION FOR PARAMETER 453 IS NOT AVAILABLE.
I am convinced that I have correctly specified the priors so I don't think that is the problem. Here's an example of prior specs for one part of the measurement model:

MODEL:
AU BY comp1-rel4*0 (X1-X8);
CO BY aut1-aut4*0 (Y1-Y4);
CO BY rel1-rel4*0 (Y5-Y8);
RE BY aut1-comp4*0 (Z1-Z8);
aut1 on aut2@0;
aut1-rel4 (Q1-Q12);
aut1-rel4 with aut1-rel4 (Q13-Q78);
MODEL PRIORS:
X1-X8~N(0,.01);
Y1-Y8~N(0,.01);
Z1-Z8~N(0,.01);
Q1-Q12~IW(1,18);
Q13-Q78~IW(0,18);

I've tried simplifying the model to try to identify the problem source but get the same error (but with a different parameter number, obviously).

Any help would be gratefully received.
Thank you,
David.
 Linda K. Muthen posted on Thursday, December 05, 2013 - 11:48 am
Please send the output and your license number to support@statmodel.com. Be sure the output has TECH1.
 David Markland posted on Thursday, December 05, 2013 - 5:11 pm
Thank you Linda. I'll do that.
David.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: