Multiple Mediations. Troubles with fi... PreviousNext
Mplus Discussion > Structural Equation Modeling >
Message/Author
 Nils Henker posted on Monday, September 26, 2011 - 8:34 am
Hallo,

i conducted a path analysis with Mplus.

I used this syntax:

model:

B on A;
C on AB;
E on ABC;


model indirect:

A ind B A;
E ind C B A;


This model had a perfect fit.

Then I added a second mediator for the relation between B and E. I used this syntax:


model:

B on A;
C D on AB;
E on ABCD;


model indirect:

C ind B A;
D ind B A;
E ind C B A;
E ind D B A;

Now the model fit indices are really bad.
Does anyone know why the model fit droped from perfect to very bad just because I added a second mediator?

Best regards,

Nils
 Linda K. Muthen posted on Monday, September 26, 2011 - 11:48 am
The first model is just-identified so model fit is not relevant. The second model has one degree of freedom. Leaving out that path causes the model not to fit the data.
 Nils Henker posted on Wednesday, September 28, 2011 - 2:40 am
Thank you very much.
 Ann Chen posted on Wednesday, September 28, 2011 - 9:33 am
Dear Dr. Muthén,

I have a multiple mediations model with zero CFI and negative TLI. I'm not sure what does this mean? Poor model fit? But I got aceeptable RMSEA and SRMR. The following is the tests of model fit:

TESTS OF MODEL FIT

Chi-Square Test of Model Fit
Value 12.217
DF 11
P-value 0.3476

Chi-Square Test of Model Fit for the
Baseline Model
Value 20.001
DF 20
P-value 0.4579

CFI/TLI
CFI 0.000
TLI -2009.133

RMSEA
Estimate 0.029

SRMR
Value=0.051

I appreciate any comments and suggestions.

Thank you.

Best,
Ann
 Linda K. Muthen posted on Wednesday, September 28, 2011 - 10:40 am
Please send the full output and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: