Conditional LCGA/GMM with missing data PreviousNext
Mplus Discussion > Growth Modeling of Longitudinal Data >
 Lina Homman posted on Saturday, July 06, 2013 - 7:37 pm
Dear Dr & Dr Muthen,

I am running unconditional and conditional LCGA and GMM models. There is missing data on all variables. As FIML is used in mplus, I assumed this ok for the unconditional models. However, when I run unconditional models I loose all the subjects with missing on any of the covariates. I have a total of about 4000 subjects and loose about 700. I wish to compare the unconditional and conditional models and therefore wish the number of observations to be the same. I tried to fix this by adding the variance to the models. The output then told me I had to add ALGORITHM=INTEGRATION. Which resulted in the output error: FATAL ERROR RECIPROCAL INTERACTION PROBLEM. I therefore tried to take a different approach by imputing the missing data in the covariates. I tried this with both stata and mplus. I am really new to imputations. In mplus when I try to use the imputed data I get:"ERROR
The number of observations is 0. Check your data and format statement". Why is this? I have added type=imputation to my syntax under data. From stata I am not sure how mplus reads the new data file. Also, is it ok to allow mplus to use FIML on the outcome variables and multiple imputation on the covariates or shall I use multiple imputation on all variables?

Many thanks in advance for you help and for mplus:-)

 Linda K. Muthen posted on Sunday, July 07, 2013 - 7:51 pm
You need to send the files and your license number to It is impossible to sort this out without more information.
 Lina Homman posted on Tuesday, July 09, 2013 - 2:46 pm
Thanks for your reply. I think I have solved the problem. However, just one last question. I decided to go with using multiple imputations for my covariates and managed to get it to work. But most of my covariates are binary. Do I need to specify this in the syntax or does Mplus deal with it?(I read that when adding variances of the covariates as to not loose subjects due to missing data on covariates, Mplus treats the covariates as continuous).

many thanks
 Lina Homman posted on Tuesday, July 09, 2013 - 2:50 pm
Problem solved, it is just by adding a (c) after each categorical variable in the Impute command, correct?

 Linda K. Muthen posted on Tuesday, July 09, 2013 - 2:52 pm
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message