Error Message PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
Message/Author
 Jeremy Miles posted on Sunday, February 23, 2003 - 3:37 am
I am running a fairly simple CFA (2 factors, 10 measures), and I get an error message which pops up in a window and says "Mplus has unexpectedly stopped running. The output may contain only partial output. Please try again. If you continue to have problems with this input file please email it to Mplus support". However, the output seems to contain everything I expect it to. Should I be worried by this message?
 Linda K. Muthen posted on Sunday, February 23, 2003 - 6:40 am
If you send your input or output and data to support@statmodel.com, I will look into it. I have never seen a situation where one gets a complete output when that message pops up.
 Anonymous posted on Sunday, January 30, 2005 - 10:14 pm
What would cause MPLUS to identify a continuous variable as dichotomous?

I am using the following analysis instructions:
type=mgroup;
iterations=1000;
PARAMETERIZATION=THETA; estimator= WLSMV;

I am getting the FATAL ERROR message below for four observed continuous indicators of two latent variables.

VARIABLE IIE73 CAUSES A SINGULAR WEIGHT MATRIX PART. THIS MAY BE DUE TO THE VARIABLE BEING DICHOTOMOUS BUT DECLARED AS CONTINUOUS.
RESPECIFY THE VARIABLE AS CATEGORICAL.

Thank you for your help
 Linda K. Muthen posted on Monday, January 31, 2005 - 8:44 pm
You are most likely reading your data incorrectly. Be sure that you do not have blanks in your data as a missing value flag. If you do and you are reading your data free format, then your data are not being read correctly. If you continue to have problems, send your output and data to support@statmodel.com.
 Angelos Alexopoulos posted on Thursday, October 06, 2005 - 9:13 am
I run a CFA (Principal Axis Factoring, conducting oblique factor rotation [oblimin]) using SPSS and was faced with the following message: 'Attempted to extract 6 factors. In iteration 25, the communality of a variable exceeded 1.0.Extraction was terminated'. The strange thing is that when I re-run EFA I had no problems with factor loadings etc. Sample size is n=272; number of (ordinal) variables is 6. Any ideas why did this occur? Thanks a lot in advance.
 Linda K. Muthen posted on Saturday, October 08, 2005 - 10:54 am
It sounds like you are using two different estimators and that is why your results are different. Also, you don't mention whether all of your analyes are using SPSS. In addition, you cannot extract six factors from only six variables.
 HWard posted on Thursday, December 15, 2005 - 1:55 pm
In trying to create a 3-factor latent measure of 'diet', I am getting an error message which indicates that only one factor can be used to define diet. is this because these variables should not be combined into a factor analytic model?


INPUT INSTRUCTIONS

TITLE: measurement model first attempt

DATA:
FILE IS "C:\Documents and Settings\Owner\My Documents\fruit.csv";

VARIABLE:
NAMES ARE VEG FRUIT GRAINS SEXNUM;
USEVARIABLES ARE VEG FRUIT GRAINS;
MISSING ARE ALL (-999);


ANALYSIS:
TYPE IS EFA 2 3 ;
ESTIMATOR = ML;
ITERATIONS = 1000;

MODEL: DIET by fruit veg grains;




*** WARNING
Too many factors were requested for EFA.
The maximum number of factors is set to 1.
1 WARNING(S) FOUND IN THE INPUT INSTRUCTIONS
 Linda K. Muthen posted on Thursday, December 15, 2005 - 2:53 pm
You cannot extract more than one factor from three indicators. The model would not be identified.
 HWard posted on Friday, December 16, 2005 - 7:18 am
Right - I'm trying to do get one factor only (DIET) from three indicators (FRUIT VEG GRAINS) - that's why I'm confused by the error message. Is it a problem with my coding?
 Linda K. Muthen posted on Friday, December 16, 2005 - 8:03 am
When you say

TYPE IS EFA 2 3 ;

this is asking the program to extract a two-factor solution and a three factor solution from the data. If you want a one factor solution, then say

TYPE IS EFA 1 1 ;
 mariachiara colucci posted on Tuesday, December 20, 2005 - 9:23 am
I'm doing an exploratory factor analysis with SPSS, using the principal axis factoring (for a construct measured with 3 items). I got the following message: "in iteration 25 the communality of a variable exceeded 1.0. extraction was terminated". what does it mean? how can I get the factor?
 bmuthen posted on Tuesday, December 20, 2005 - 9:30 am
You should contact the SPSS customer support, but it sounds like you have a "Heywood case", which means that you have a negative residual variance, which in turn suggests either that your sample is quite small or that the factor model is not suitable for these data.
 Fieke Schopenhouer posted on Tuesday, January 17, 2006 - 3:45 am
I am trying to create a CFA Model, with four factors, 11 factor indices and 5 groups. However, when mplus is running I obtain the following error message:

INPUT INSTRUCTIONS

TITLE: Fieke

DATA:
FILE IS "D:\dataspss.dat";

VARIABLE:
NAMES ARE country inno1 inno2 inno3 inno4 quality inno5 custsat
custloy emplsat emplret emplloc;
USEVARIABLES ARE country inno1 inno2 inno3 inno4 quality inno5
custsat custloy emplsat emplret emplloc;
GROUPING IS country (1 = UnitedKingdom 2 = Austria 3 = Ireland 5 =
NewZealand 6 = Australia);

ANALYSIS:
TYPE IS MEANSTRUCTURE;
ESTIMATOR IS ML;
ITERATIONS = 10000;
CONVERGENCE = 0.00001;

MODEL:
f1 BY inno1 inno2 inno3 inno4 inno5;
f2 BY quality;
f3 BY custsat custloy;
f4 BY emplsat emplret emplloc;
f1 ON f1 f2 f3;

*** ERROR
Unexpected end of file reached in data file.

My data is in a notepad file. What am I doing wrong?
 Linda K. Muthen posted on Tuesday, January 17, 2006 - 8:12 am
It sounds like you are not reading your data correctly. You either have blanks in your data which is not allowed with free format or the number of variable names does not match the number of variables in the data set. If you cannot figure this out, send your input, data, output, and license number to support@statmodel.com.
 nicole simoes posted on Friday, May 05, 2006 - 10:05 am
The program isn't letting me run a confirmatory factor analysis, instead it terminates in a fatal error, saying that the degrees of freedom in my model is negative. Where would this be specified in my data set and how can I fix it?
 Linda K. Muthen posted on Friday, May 05, 2006 - 10:25 am
You need to send your input, data, output, and license number to support@statmodel.com. so we can look at your model.
 Carol Van Hulle posted on Tuesday, June 27, 2006 - 9:59 am
Hi,

I am running a confirmatory factor analysis with 9 factors. In the new version of Mplus I get several error messages like the following:

WARNING: THE SAMPLE CORRELATION OF PMUG AND PCARS IS -0.997
DUE TO ONE OR MORE ZERO CELLS IN THEIR BIVARIATE TABLE.
INFORMATION FROM THESE VARIABLES CAN BE USED TO CREATE ONE NEW VARIABLE.

All variables are categorical with scores 0, 1, and 2. I'm not sure what the meaning of this message is, as everyone should have a score for each variable.

I should note that all of the error messages pertain to one factor.

Thanks,
Carol
 Linda K. Muthen posted on Wednesday, June 28, 2006 - 2:20 am
Look at the bivariate table for the two variables to see the problem. Bivariate tables should have no zero cells. You may want to delete one of the items.
 Carol Van Hulle posted on Monday, July 17, 2006 - 12:06 pm
Dear Dr. Muthen,

Please pardon my ignorance, here. Won't there always be some zero cells if my CFA includes items that are rarely endorsed?

For instance, suppose I want to do a CFA on delinquency, positing a separate factor for aggression and property crimes. Included in my measure of aggression are the items "threatened with a knife" and "kidnapped someone." It is entirely possible that with two such extreme items no one in my sample will endorse both of them. Does that mean I have to throw one or both items out of my factor analysis?

Thank you.
 Linda K. Muthen posted on Monday, July 17, 2006 - 12:22 pm
Data of this type require larger sample sizes to avoid the zero cell problem.
 Kristine Amlund Hagen posted on Monday, December 11, 2006 - 4:28 am
Dear Drs. Muthen,

I have been working on my CFA model, when suddenly, after several successful runs,
I get the following message:


*** ERROR
Unable to expand (-999.0)

I have specified that -999.0 means missing
value and I have trippel-checked that missing values are indeed designated
-999.0 in my textfile.
 Linda K. Muthen posted on Monday, December 11, 2006 - 6:02 am
Please send your input, data, output, and license number to support@statmodel.com. We need more information to understand what the problem is.
 craig neumann posted on Saturday, May 05, 2007 - 1:13 pm
Dear Drs. Muthen, I usually use raw items for all CFAs but in the case below I tried to use summary data and received an error that I've never seen before nor can if figure out what's wrong with the program.

INPUT INSTRUCTIONS

TITLE: pclR H4 via cooke BJP covar HMP Sample

DATA:
FILE IS cooke-BJP-covar2.txt;
TYPE IS CORRELATION;
NOBSERVATIONS = 827;

VARIABLE: NAMES ARE
PCLA1 PCLA2 PCLA3 PCLA4 PCLA5 PCLA6 PCLA7 PCLA8
PCLA9 PCLA10 PCLA11 PCLA12 PCLA13 PCLA14 PCLA15 PCLA16
PCLA17 PCLA18 PCLA19 PCLA20;
usevariables are PCLA1 PCLA2 PCLA3 PCLA4 PCLA5 PCLA6 PCLA7 PCLA8
PCLA9 PCLA10 PCLA12 PCLA13 PCLA14 PCLA15 PCLA16
PCLA18 PCLA19 PCLA20;
CATEGORICAL ARE PCLA1 PCLA2 PCLA3 PCLA4 PCLA5 PCLA6 PCLA7 PCLA8
PCLA9 PCLA10 PCLA12 PCLA13 PCLA14 PCLA15 PCLA16
PCLA18 PCLA19 PCLA20;

MODEL:
F1 BY PCLa1 PCLa2 PCLa4 PCLa5;
F2 BY PCLa6 PCLa7 PCLa8 PCLa16;
F3 BY PCLa3 PCLa9 PCLa13 PCLa14 PCLa15;
F4 BY PCLa10 PCLa12 PCLa18 PCLa19 PCLA20;


ANALYSIS:
TYPE IS GENERAL;
ESTIMATOR IS ML;
ITERATIONS = 1000;
CONVERGENCE = 0.00005;

OUTPUT: SAMPSTAT STANDARDIZED;

*** ERROR
No 'VARIABLE: NAMES' statement
 Linda K. Muthen posted on Sunday, May 06, 2007 - 6:09 am
Please send your input, data, output, and license number to support@statmodel.com.
 socrates posted on Thursday, June 14, 2007 - 3:10 am
Dear Dr. Muthén

Running a CFA I got the following error message:

WARNING: THE RESIDUAL COVARIANCE MATRIX (PSI) IS NOT POSITIVE DEFINITE. PROBLEM INVOLVING VARIABLE DEP.

DEP is one of the six factors and has correlations gerater than 1 with other factors.

Do you have any suggestion how to deal with this problem?

Thank you very much!
 Linda K. Muthen posted on Thursday, June 14, 2007 - 9:21 am
Factors will correlations greater than one are not statistically distinguishable. You will need to change your model.
 Lois Downey posted on Wednesday, November 28, 2007 - 10:26 am
For a confirmatory factor analysis with dichotomous indicators, should my goal be to eliminate ALL occurrences of empty cells in the bivariate tables, or is it sufficient just to eliminate MOST occurrences?
 Linda K. Muthen posted on Wednesday, November 28, 2007 - 2:34 pm
You should have no empty cells. An empty cell implies a correlation of one.
 Erika Wolf posted on Saturday, July 05, 2008 - 11:45 am
I've been running a series of twin analyses and had problems with multiple empty cells in the tetrachoric correlation matrix. I managed to reduce that error message down to just 1 error by eliminating psychiatric diagnoses that were very low base rate in the epidemiological sample I'm working with. However, the 1 empty cell that I'm left with is problematic because, conceptually, I can't eliminate either variable (they are both too important) and I can't combine them, because, again, conceptually, the disorders are quite different from one another (a pure anxiety disorder vs. anti-social behavior). The message I'm getting indicates that the empty cell is between Twin A on the anxiety disorder and Twin B on the antisocial disorder. How do you suggest I proceed? Is there any work around?
 Bengt O. Muthen posted on Sunday, July 06, 2008 - 9:36 am
It might be worth thinking about this because it seems strange that two conceptually different disorders would be so closely tied as to give a zero cell in their crosstab - unless the sample size is too small relative to the rare outcomes so that it is likely to happen as a random event. You can ignore it and see if model estimates come out reasonably - perhaps with only one such problematic pair the distortion would not be big. Or you could try switching to ML which does not avoid the problem but may (or may not) suffer less. ML is however heavy with many dimensions.
 Erika Wolf posted on Monday, July 07, 2008 - 9:24 am
Thanks for your response. The sample size is large (over 3000 pairs of twins), but the base rate of the disorders are low (< 5%) because it is an epidemiological sample. So I assumed the low base rate contributed to the problem. The model yields good results that are quite interpretable, so I'd like to be able to ignore the warning, but wasn't sure if that was really OK to do in this case.
 MAH posted on Thursday, July 24, 2008 - 1:02 pm
I also have been running twin analyses and am getting messages about zero cells that I think I can ignore. The situation is that I have adapted Prescott's code to create latent variables and estimate A,C,E for this latent variable. One latent var is created for twin 1 and one for twin 2, and each latent variable is based on that twin's dichotomous item indicators. Zero cells emerge when, for example, dichotomous item 1 for twin 1 is correlated with dichotomous item 9 for twin 2. However, I don't want these correlations. I want to correlate twin 1's continuous latent variable with twin 2's continuous latent variable to estimate A,C,E. So, my question is... are the zero cells ignorable and how can I adapt my program to get around this problem? I used the IRT program example 7.29 and I didn't get the error messages about the zero cell problem. Why?

Thank you!
 Linda K. Muthen posted on Thursday, July 24, 2008 - 5:17 pm
Zero cells refer to the observed data, the bivariate tables for each pair of observed data. A zero cell implies a correlation of one. This should not be ignored. It happens when the sample size is too small.

The message you can ignore is the one about a correlation of one since the model imposes that.
 Charlotte McClelland posted on Wednesday, September 24, 2008 - 3:57 am
Dear Dr. Muthen,

I am running a CFA and I have received this warning:

WARNING: THE RESIDUAL COVARIANCE MATRIX (THETA) IS NOT POSITIVE DEFINITE.
THIS COULD INDICATE A NEGATIVE VARIANCE/RESIDUAL VARIANCE FOR AN OBSERVED
VARIABLE, A CORRELATION GREATER OR EQUAL TO ONE BETWEEN TWO OBSERVED
VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE THAN TWO OBSERVED VARIABLES.
CHECK THE RESULTS SECTION FOR MORE INFORMATION.
PROBLEM INVOLVING VARIABLE GDIF1_6.

Indeed, my GDIF1_6 variable has a correlation of more than 1, and a negative residual. It's one item in a two item scale that is very important in my model; the rest of the model fits relatively well.

Are there any solutions for dealing with these problem variables, other than taking them out? It has been suggested to me that I could attempt to classify the variable as a categorical var as opposed to continuous - what do you think about this?

Many thanks, Charlotte
 Linda K. Muthen posted on Wednesday, September 24, 2008 - 7:31 am
It sounds like there is a misfit related to this factor. Perhaps the two indicators relate to other variables in the model differently from each other in a way that does not fit with their one-factor model. If GDIF1_6 correlates greater than one with another variable, it or the other variable should be removed from the analysis. The two items are not statistically distinguishable. Having a negative residual variance is one more strike against it. I would use the other indicator as an observed variable in the analysis. A factor with only two indicators is not identified without borrowing from other parts of the model. This makes it not very believable. If the variable is categorical, you can treat it as such but I don't think that is important.
 William Welch posted on Tuesday, May 26, 2009 - 11:31 am
Hi,
Using the same number of variables, I am fitting models with different numbers of factors. My eight- and four-factor models terminate normally, but my one-factor solution says, "no convergence. number of iterations exceeded." I don't expect this model to fit better than the eight- or four-factor models, but can I just report "no convergence" in a journal article or do I have to report statistics for a model that converges? If so, how can I reach convergence (e.g., increase the number of iterations)?

All variables are continuous
Estimator: ML
Information matrix: OBSERVED
Maximum number of iterations: 1000
Convergence criterion: 0.500D-04
Maximum number of steepest descent iterations: 20

Thank you.
 Linda K. Muthen posted on Tuesday, May 26, 2009 - 11:50 am
Please send your input, data, output, and license number to support@statmodel.com.
 Jason Pierce posted on Thursday, August 06, 2009 - 8:45 am
Hi,

I received the error message below. In this case, parameter 65 is the var's entry in the theta matrix.

Since I saw no unusual correlations, variances,residual variances, or value in the THETA matrix for the item in question, I removed the item to see if the problem was elsewhere.

Sure enough, the problem moved to another item. When I removed that item (without replacing the first item), the problem moved again to a different item.

If I keep going like this, I'll have a nulll model. Does anyone have any recommendations regarding this situation?

Thanks,
Jason

THE MODEL ESTIMATION TERMINATED NORMALLY

THE STANDARD ERRORS OF THE MODEL PARAMETER ESTIMATES MAY NOT BE
TRUSTWORTHY FOR SOME PARAMETERS DUE TO A NON-POSITIVE DEFINITE
FIRST-ORDER DERIVATIVE PRODUCT MATRIX. THIS MAY BE DUE TO THE STARTING
VALUES BUT MAY ALSO BE AN INDICATION OF MODEL NONIDENTIFICATION. THE
CONDITION NUMBER IS -0.167D-15. PROBLEM INVOLVING PARAMETER 65.
 Linda K. Muthen posted on Thursday, August 06, 2009 - 11:03 am
Please send your input, data, output, and license number to support@statmodel.com.
 Kerry Lee posted on Monday, September 20, 2010 - 3:00 am
Dear Dr Muthen,

I am new to Mplus and am having some teething problems. I have a large data file with 400 odd variables. After spending the day recoding error codes and renaming variables, I am getting the following error message when i try to read the file:

Variable: ...
PSswAC3T FLinAC2T SIinAC2T MXmem2T LRmem2T RSnon2T FLswAC2T SIswAC2T PSswAC2T
FLinAC1T SIinAC1T MXmemT LRmemT RSnonT FLswAC1T SIswAC1t PSswAC1T

MISSING ARE ALL (11111-123456);

ANALYSIS:
TYPE IS basic;

*** ERROR
Unable to expand: (11111-123456)

Is there a limit to the number of error codes that can be read? I have about 15 of them in SPSS (11111, 22222, 33333, etc.)

Thanks,
Kerry.
 Linda K. Muthen posted on Monday, September 20, 2010 - 9:26 am
There is no limit to the number of missing value flags.

We tried an example like yours and had no problem. Please send the full output and your license number to support@statmodel.com.
 Jen posted on Wednesday, September 22, 2010 - 9:02 am
Hello,

I am working on a latent growth model with 13 time points (N=400+). One of the variables I hope to model is binary, indicating whether a participant has ever done a behavior. Therefore, once a participant becomes a "1", there is never a change back to "0", resulting in empty cells and many error messages. Eventually I hope to build a two-part LGM with the binary variable as well as a continuous variable (with the two growth processes correlated). Is it possible to model the binary data, or is this type of data inappropriate for LGM?

Thanks for your help,
Jen
 Linda K. Muthen posted on Wednesday, September 22, 2010 - 11:15 am
I think you should use a discrete-time survival model for your binary variable. It seems more appropriate for a behavior that cannot change once it occurs.
 Janet Smith posted on Tuesday, November 02, 2010 - 12:52 pm
Please can you help me understand an error message.

I am trying to run a simple CFA to prepare for SEM. Here are my input instructions:

INPUT INSTRUCTIONS

TITLE: AS SEM;
DATA: FILE IS as.dat;
VARIABLE: NAMES ARE id q b1-2 e1-2 c1 v1-5
MISSING ARE ALL (-999)

MODEL:
f1 BY v1-5

OUTPUT: TECH1 TECH8;

Then I get the following error message.

*** ERROR
Unable to expand: B1-2

I get the same error message no matter which variables I list or data set I use.

Thanks in advance for your help.
 Linda K. Muthen posted on Tuesday, November 02, 2010 - 1:35 pm
The list must have the same stem, for example, b1-b2 instead of b1-2.
 Kerry Lee posted on Tuesday, October 04, 2011 - 8:01 pm
Dear Drs. Muthen,

I am running a modified multitrait-multitask CFA and am testing whether the data are better described by a unidimensional or 2/3 factor model.

Different age groups are involved and I am running them separately. For some groups, I am getting the following message.

THE MODEL ESTIMATION TERMINATED NORMALLY

WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE
DEFINITE. THIS COULD INDICATE A NEGATIVE VARIANCE/RESIDUAL VARIANCE FOR A
LATENT VARIABLE, A CORRELATION GREATER OR EQUAL TO ONE BETWEEN TWO LATENT
VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE THAN TWO LATENT VARIABLES.
CHECK THE TECH4 OUTPUT FOR MORE INFORMATION.
PROBLEM INVOLVING VARIABLE FLCNRTQ.

Inspection of TECH 4 shows that two of the latents are very strongly correlated (r = .806), but there was nothing equal to or greater than one. Furthermore, the variable FLCNRTQ is not a latent (but for some reason, it was included in the TECH 4 output). Its estimated correlations with other variables are also within bound.

I am puzzled by the cause of the error message and the inclusion of an observed variable in TECH 4. Would you have some suggestions?

Sincerely,
Kerry.
 Bengt O. Muthen posted on Tuesday, October 04, 2011 - 8:56 pm
An observed variable is included among the latents if for instance there is a variable predicting this variable - then a factor gets put behind it, for which the observed variable is taken to be a perfect indicator. So this is harmless. Note that correlations don't need to be 1 for non-pos definiteness, but the overall pattern of elements can create this problem.

If you like, you can send your output and license number to Support.
 Lisa M. Yarnell posted on Tuesday, April 24, 2012 - 6:32 pm
Hi Linda and Bengt,

One variable in my 2-group cross-lagged (longitudinal) model is dichotomous in one group, but continuous in the other group.

In theory, the variable ranges from 0 to 10, and one group endorses a wide variety of values on this scale (0 to 8), but the other group endorses only 0's and 1's.

While this is an interesting finding in itself, it yields the following error message for my cross-lagged model:

THE STANDARD ERRORS OF THE MODEL PARAMETER ESTIMATES MAY NOT BE TRUSTWORTHY FOR SOME PARAMETERS DUE TO A NON-POSITIVE DEFINITE FIRST-ORDER DERIVATIVE PRODUCT MATRIX. THIS MAY BE DUE TO THE STARTING VALUES BUT MAY ALSO BE AN INDICATION OF MODEL NONIDENTIFICATION. THE CONDITION NUMBER IS 0.407D-16. PROBLEM INVOLVING PARAMETER 29.

THIS IS MOST LIKELY DUE TO VARIABLE ANX30 BEING DICHOTOMOUS BUT DECLARED AS CONTINUOUS.

Is it possible to declare the variable as dichtomous in just one group? Will estimation problems arise from leaving it declared as continuous in both groups?

Or, is this an essential difference in the variables used, such that I should run the models in two entirely separate programs, rather than a two-group model in one program?

Thanks!
 Linda K. Muthen posted on Wednesday, April 25, 2012 - 10:44 am
As long as you are certain that the message comes from the one group having on 0's and 1's, I would ignore the message. In this case, it is caused by the fact that the mean and variance of a binary variable are not orthogonal.
 ide katrine birkeland posted on Friday, May 18, 2012 - 5:41 am
Dear Dr. Muthens,

I am running a fairly simple SEM model with mediation (N=385, latent variables=9).

I get the following error message:
THE STANDARD ERRORS OF THE MODEL PARAMETER ESTIMATES COULD NOT BE
COMPUTED. THE MODEL MAY NOT BE IDENTIFIED. CHECK YOUR MODEL.
PROBLEM INVOLVING PARAMETER 213.

THE CONDITION NUMBER IS -0.823D-07.

Tech 1 tells me that Parameter 213 is situated in the PSI and with the same latent variable (OP with OP)

I do not know how to go forward with this information, can you please point me in the right direction?

Thank you.
 Linda K. Muthen posted on Friday, May 18, 2012 - 6:30 am
Please send your output and license number to support@statmodel.com.
 anonymous posted on Monday, September 23, 2013 - 7:51 am
I'm running a CFA with 15 categorical variables and I get the warning message "THERE IS NOT ENOUGH MEMORY SPACE TO RUN Mplus ON THE CURRENT INPUT FILE." When I tried also including ALGORITHM=INTEGRATION and INTEGRATION=MONTECARLO (5000), the model successfully runs but then I no longer get the fit indices (e.g. CFI, RMSEA, etc.). Is there a way to both address the error message and get the fit indices to run?
 Linda K. Muthen posted on Monday, September 23, 2013 - 1:44 pm
Chi-square and related fit statistics are not available with ML and categorical outcomes. These are available for models where means, variances, and covariances are sufficient statistics for model estimation.
 Heather Gilmartin posted on Friday, February 07, 2014 - 2:26 pm
I am just starting with Mplus and am attempting to run a CFA. I keep getting an error message - can you help? See input and output below.

02/07/2014 1:23 PM

INPUT INSTRUCTIONS

TITLE: RC CFA FEB7
DATA: FILE IS /Users/chantler/
Dropbox/Dissertation Folder/
Data Files/February Files/Feb 7_Mplus RC/
307_RC_CFA_Feb7.dat;
FORMAT = 28f2.0;

VARIABLE:
NAMES = mdcommfr mdcommti
mdcommac mdcommbl mdcommkn
mdcommre mdcommsh ncommfr
ncommti ncommac ncommbl
ncommkn ncommre ncommsh
ecommfr ecommti ecommac ecommbl
ecommkn ecommre ecommsh hacommfr
hacommti hacommac hacommbl hacommkn
hacommre hacommsh;
USEVARIABLES ARE ALL;
MISSING ARE ALL ;

ANALYSIS:
type = basic;

*** ERROR in DATA command
The file specified for the FILE option cannot be found. Check that this
file exists: /Users/chantler/ Dropbox/Dissertation Folder/ Data Files/February Files/Feb 7_Mplus
 Linda K. Muthen posted on Friday, February 07, 2014 - 6:28 pm
Mplus seems to detect an extra space before the folder "Data Files". Try putting as much of the file name on the same line.
 Jane Jiang posted on Sunday, March 23, 2014 - 4:56 pm
Dear Dr. Muthen,

When I run the input file, there is an error message everytime:

"Mplus was unable to start. Please try again....."

My system is Windows8. I have set the "PATH variable environment" following your instructions on the website, but it still does not work. Is there any other possible reasons? Thank you!

Best,
Jane
 Linda K. Muthen posted on Sunday, March 23, 2014 - 6:28 pm
It can also mean that you need to reboot your computer or that you have more than one copy of Mplus.exe on your computer.
 Mahdi posted on Tuesday, April 15, 2014 - 2:44 pm
Dear Prof Muthén,
I run CFA and I saw this message in output:
WARNING: THE LATENT VARIABLE COVARIANCE MATRIX (PSI) IS NOT POSITIVE
DEFINITE. THIS COULD INDICATE A NEGATIVE VARIANCE/RESIDUAL VARIANCE FOR A LATENT VARIABLE, A CORRELATION GREATER OR EQUAL TO ONE BETWEEN TWO LATENT VARIABLES, OR A LINEAR DEPENDENCY AMONG MORE THAN TWO LATENT VARIABLES. CHECK THE TECH4 OUTPUT FOR MORE INFORMATION. PROBLEM INVOLVING VARIABLE TC1.
TC1 is one of my indicators. I recheck the TECH4 output and StdYX. The correlation between TC1 and Factor4 is 1.454 (I guessed there is dependency between our indicators), then I removed this indicator from CFA model and the output was as follow:
(RMSEA=0.09, CFI/TLI=0.94/0.95, and SRMR=0.04) with no warning message.
My question is: Is there another way for solving this problem? (without removing our indicator(s)?)
 Bengt O. Muthen posted on Tuesday, April 15, 2014 - 7:03 pm
Do an EFA and see if there are cross-loadings. CFA specifying zero cross-loadings can give rise to too high factor correlations when that specification is wrong.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: