Factor interactions PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
Message/Author
 Anonymous posted on Tuesday, August 16, 2005 - 4:24 am
I have a model with 2 factors each with categorical indicators. The model includes an interaction between the 2 factors. I have declared the indicators as categorical.

Usinc Mplus 3.0 the model ran fine. However, using Mplus 3.12 I get the following message(please note the syntax is identical for both runs):

*** ERROR in Model command The categorical variables in the growth model do not have the same number of categories. Use the CATEGORICAL option to allow the number of categories to differ for maximum likelihood estimation. Problem with: Factor1
 Linda K. Muthen posted on Tuesday, August 16, 2005 - 12:35 pm
You would need to send the input, data, output, and your license number to support@statmodel.com to get an answer to this question. Please send both the 3.0 and 3.12 outputs if you have them
 Anonymous posted on Wednesday, August 17, 2005 - 5:39 am
As luck would have it...I figured it out after posting the message. The issue was that the original code that ran in 3.0 but not 3.12 was set up as follows:
F1|y1 y2 y3 y4
F2|y1 y2 y3 y4 y5

This did not run in 3.12. I changed the above code by changig the "|" with "by" (as below)
F1 by y1 y2 y3 y4
F2 by y1 y2 y3 y4 y5

Thank you.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: