ACE/ADE with WLSMV and DIFFTEST PreviousNext
Mplus Discussion > Structural Equation Modeling >
 Michael J Zyphur posted on Wednesday, November 01, 2006 - 7:19 pm
Hi Bengt,
As noted recently by Dominicus, Skrondal, Gjessing, Pedersen, & Palmgren (2006), LRT difference tests in ACE/ADE models are biased because they test variances at the boundaries of the parameters' spaces (i.e., at 0). These authors derive solutions for correcting p-values based on the mixture of chi-square distributions produced in ACE/ADE difference tests.

I am running ACE/ADE models with categorical variables, meaning that WLSMV is employed by default. Thus, I am using the statistical theory underlying the DIFFTEST option in Mplus (as per the webnote).

My question is this: Because DIFFTEST in this case relies on a test of the parameter of interest at the boundary of its space, may I simply correct the provided DIFFTEST chi-square value in line with Dominicus et al. (2006), or is a correction required before DIFFTEST is performed?

Thanks for your help!!


Dominicus, Skrondal, Gjessing, Pedersen, & Palmgren (2006). Likelihood ratio tests in behavioral genetics: Problems and solutions. Behavior Genetics, 36, 331-340.

P.S. I hope you're enjoying your retirement!
 Linda K. Muthen posted on Thursday, November 02, 2006 - 1:09 pm
I think if any correction were made it should be during the process not after. DIFFTEST should not be used when the parameter of interest is on the boundary.
 Erika Wolf posted on Thursday, May 29, 2008 - 1:50 pm
I seem to have a smiliar issue: I'm trying to examine the chi square difference test of nested models. The data are categorical and are used as indicators of two continuous latent factors. The parent model is the full ACE model, the nested model constrains the C path for 1 latent factor to 0 and the E path for the other latent factor to 0. I'm trying to use the DIFFTEST option to compute the difference in chi square between these models, but it won't compute the nested chi square and I think this is due to the parameter estimates being close to 0 in the parent model. Is there anyway to evaluate the change in chi square in this scenerio? Thanks.
 Linda K. Muthen posted on Thursday, May 29, 2008 - 2:12 pm
Please send the relevant files and your license number to It is not possible to know the reason without further information.
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message